Auto Z Touch Plate Issues introduced with V2.4.2 Mach4 software

Machine Info: 4896 Pro CNC with 4th Axis rotary. Purchased: January 2019

I recently ran into an issue I haven’t experienced sine acquiring my 4896 PRO with rotary axis. It all began after updated to the newest version of Mach4 on the Avid Software page ( Avid CNC Mach4 Version 2.4.2 (3.10.2023) and there doesn’t seem to be a way to roll back to test if it is a software issue. I am unsure if the issue is related to the newest version so reaching out here to see if anyone else has seen this. When I use the touch plate to get my Z height on the Rotary 4th Axis, it now consistently places the bit roughly 1-2mm above the center. I have run through the frame alignment multiple times to within 0.002" and performed the touch plate offset using a 1/4" bit.

Issues Experienced since V2.4.2:

  1. Z-touch is always 2mm above center while using touch plate.
  2. When performing the Frame Alignment script, after testing the tail and chuck alignment, it does the Mid-Frame alignment. There is an option to repeat Mid-Frame Alignment after adjusting. If I simply press the repeat mid-frame alignment the distance it says to raise the mid frame keeps increasing with each z touch. If it is off 0.005" it then increases to 0.012" then 0.038" etc…with varying amounts.
  3. Another issue that has happened a few times somewhat sporadic. When running the z touch plate height offset script with the rod in chuck and second magnet attachment. Sometimes the bit will register on the top of the bar, but when probing the sides, it will begin to move the rod and not register it the second or third time and have to hit the emergency stop, fix and repeat. This issue began before updating software a few months ago.
  4. After using the Y-axis align script withe Z touch plate, it doesn’t put the bit in the center of the rotary axis, it looks 1-2" off from center.
  5. The machine hasn’t moved or changed in any way yet all of a sudden it tells me that I am off by 0.04" in various aspects forcing me to spend 2 days to attempt to re-align to find the values constantly changing on repeat alignments.

Issues gone after reverting to V2.3.8

  1. The bit appears to align to center of rotary axis now. Although it appears slightly off by a couple thousands of an inch. Repeat produces same result. No longer ~2mm off center experienced in V2.4.2

  2. Mid-Frame alignment probe no longer changing values on repeat test.

  3. Not sure if an issue still but it worked the 2-3 tests while back on V2.3.8.

  4. Y-axis prob puts the bit in the center again.

  5. Performed alignment procedure on v.2.4.2 and get the following result 0.002" on frame alignment and 0.004" on mid-frame alignment:

  1. Did not touch or move machine whatsoever, re-installed V2.3.8 software and performed frame alignment procedure and get drastically different values which makes sense as after the V2.4.2 alignment a straight edge across the rails produced a very small amount of bend:

There aren’t active links on the Avid Software page but copying the latest link, and changing the version number to the previous version works for a download. Today I will install the prior 2.3.8 version and report back if it is solves the z-touch height issue persists to rule it out.

Edited First Post to reflect changes from reverting v2.4.2 => v2.3.8

After discovering the drastic changes in repeatability and accuracy from moving to V2.4.2 from V2.3.8 I am now curious about my upgrade to V2.3.8 from v2.3.6 as my parts began showing many month ago an extremely small misalignment in cuts that was not large enough to fail a part but large enough to visually appear and require a quick sandpaper clean up.

The issue that began in v2.3.8 was impossible for me to diagnose as I was able to get the frame alignment, z, and y zero center position within 0.001", and yet parts would contain a visual misalignment much greater. After attempting exact stop mode or ruling out an lost steps in longer cuts it wasn’t big enough an issue for me to deal with, but now after dealing such drastic changes in V2.4.2 I will work back to v2.3.6 or v2.3.2 to see if my cuts regain their prior accuracy and report back.

It might be a silly question…but do you have any tool heights set in your tool table? If you revert back to the old version, you might revert the tool table too, which might indicate why it works there and not in the new one. Just a random thought and something to check.

That was the first thing I tried. Had 0 across the board in the tool table. I uninstalled and installed 2.4.2 three times to ensure, removed all files, cleaned registry, ensured everything was a blank slate before installing v.2.4.2

The scary thing about 2.4.2 for my machine is that frame alignment and z touch all three times produced different values repeatedly running frame alignment and z touch without changing anything and restarting the scripts consistently produced different values.

After reverting back to 2.3.8 it stopped the fluctuating values and produces consistent results every run. I did the same procedure of uninstalling and cleaning system, reinstalling, then running frame alignment, z touch offset, and y-axis. The values no longer changes after running it 3 times I get 3 consistent results. I then went back to 2.3.6 as 2.3.8 gives me a very very small misalignment that is consistent. I align and check with a micro bit against the center point of the chuck and tailstock and it is extremely accurate, yet 2.3.8 for me started a small misalignment.

I cut many small parts around 2" with very fine details. So the accuracy is pretty evident when it’s off.

The miss alignment I’m referring to introduced in 2.3.8 for me was around 0.003-0.004". For version 2.4.2 it put the machine out ~0.02" (but the numbers kept changing, which was a pita to attempt to align for two days not realizing the first day that running the same program repeatedly was producing different values). Interesting enough, going from 2.3.8 to 2.3.6 produces the same exact values in alignment. 2.4.2 was off not only in z values but when running y-axis align it would put the y center all over the place within 1-2" from center after wiping computer and reinstalling 2.4.2 three times it became evident something was very wrong

Summary from typing too much info above:

  1. v2.4.2 changes values consistently and wildly misaligns my machine in Z and Y values.
  2. v2.3.8 produces consistent alignment results and functions normally but introduces a very very small misalignment in my cuts even with extremely accurate frame alignment.
  3. v2.3.6 gives the same exact proper alignment values as v2.3.8 but produces better results changing nothing on machine and running the same program.

Bummer! Sounds like you have narrowed it down to the software, which is strange. I don’t have any more ideas…but I’m following the thread just to see how it pans out.

I don’t know if the issues were specific to my year of machine build, with the custom avidcnc mach4, or if it is the upgrade of ESS since v.2.4.2 also has an ESS upgrade. Just reporting results here if anyone else experiences a similar issue and what worked for me. I’m just excited to be back to cutting parts again on Monday after almost a week of downtime testing so many scenarios. Never had an issue with machine in 4 years until this strange one but now working great again

I haven’t done the methodical testing you have, but I did notice significant misalignment while using the rotary scripts, so I stopped using them. I found my rotary centerline position with test cuts. When I load a bit, I do use the touch plate on the rotary mount, but I use the non-rotary scripts and then offset the Z value manually. Given what you’ve found, I should probably revisit the calibration. Thanks for sharing your findings.

1 Like

Have you contacted support about this? This is really methodical testing and I think it’s appropriate to direct this to them. Since we did just do a software update there may (or may not) be other reports of this, either way they’d be the ones who should see this.

Also, thanks again for testing and the great detail here.

1 Like

I initially contacted them on the weekend but haven’t updated the support ticket to this post. I’ll send them the info.

I performed cuts on 3 parts this morning (using 4th axis and a micro bit, 0.002" step over and very fine intricate details) and they cut absolutely perfect with no visible miss alignment issues on v2.3.6 for my machine :tada:

Great (on both counts) I’d give them a little bit to catch up given that it’s a Monday. DM me if you don’t hear anything in the next day or two.

To follow-up on this issue for anyone that looks back at older threads. The issues described above were all resolved in version 2.4.3. I haven’t seen any alignment issues since.

Glad to hear it! I’ll pass this along to the team