Corner finding and z touchplate

My AVID corner finding and Z touchplate has worked only about 50% of the time since I purchased it about 4 years ago. AVID support has been good at responding to my emails throughout this period. So far all attempts to get this resolved have failed. The latest response from AVID is for me to restore my profile since it may be corrupt. My questions to this group are:

  1. have any of you experienced hit or miss operation of this touch plate?
  2. Have any of you had to restore your profile? and is that a significant event?
1 Like

My first recommendation would be to follow what support told you. It shouldn’t a big deal to reinstall. I’d probably backup and then delete your current Mach 4 install first though.

Follow the steps here: Mach4 Introduction - CNC Software

Unless you have a really custom machine the settings are pretty easy to restore.

I have not had much of any issues after about 2 years of use. Per @Eric’s suggestion, I also have a slightly custom setup with some of the motors swapped/the cable management and Y axis controlled from the left side of the machine instead of the right, and I have reset (uninstall/reinstall) 2 times I believe, and both were easy to reconfigure after a refresh. I have had 1 or 2 times where an X + Z zero (without a Y zero/corner zeroing) put Mach 4 in an odd state and messed up my coordinates and I had to shut down Mach and restart it, but it was an odd case so I didn’t look into it more.

The touch plate itself has always worked fine for me. Sometimes the Z axis moves up instead of down during probing, but it’s always resolved on the next try.

I’ve restored my profile before, and for my non-custom setup, it was no big deal. At one point, I worked around some recurring issues with the rotary proximity sensor by restoring every session. This was when the rotary was still pretty new. Thankfully, that ended after one of the software updates.

3 Likes

After a couple months of use, my touch plate would stop working periodically . I suspected a loose wire connection inside the unit. After redoing the wire connections it has worked flawlessly. Might be something worth checking if you keep having problems.

Ed

1 Like

Mine had a loose screw holding the magnet on but has always worked fine.

1 Like

Mine has worked perfectly every time I’ve used it properly. The only times it doesn’t work is when I forget to attach the magnet to my collet.

1 Like

One side of my sensor doesn’t give me an accurate z height so I have to find the corner first then flip it over to measure z height using the center position. It was suggested that I can calibrate the sensor but I have not been successful

1 Like

What software updates are you referring to? I’m not aware of any software updates available from AVID or for Mach4

2 Likes

Mine has worked and still works 100% of the time no reinstall needed. I want to say I purchased in 2018 or 2019.

I would like to recommend using a laser center\edge finder. See this link;

https://lasercenteredgefinder.com/product-category/battery-powered-lcef/

I find it much more useful for referencing X,Y on a complex 3D work piece. It fits in the collet. stick with the single DOT version. The cross hair variants tend to have wideer lines making accurate placement more difficult.

I’ve been using this for years.

I’ve had no problem with the touchplate, but have had the profile get corrupted once when I mistakenly turned off the controller before exiting Mach4, which is a no-no. Some touchplate things to remember: (1) As Clarryr noted, make sure you’ve attached the magnet at the end of the blue wire to the tool or spindle before starting the auto-z routine (!), and make sure the tool diameter is properly reflected in the auto-z dialog box. Also, for best accuracy, use a short steel dowel (.25" diam works fine) - easy to find and cheap on Amazon - rather than an endmill. That will correctly zero X and Y. When you chuck up the actual tool you want to use, auto-zero the Z axis only (unless the tool is of the same diam as your dowel, in which case this second step in unnecessary).

1 Like

I had problems when I put the magnet on the collet nut. Since then it always goes directly on the bit.

1 Like

Two things to consider.
Make sure the magnet is on the tool not the tool chuck. Possibly anodized of the chuck will insulate.
Try electrically isolating the bottom of the touch-plate (the part that touches the material to be machined). Use Kapton tape (or equal) on the bottom surfaces (x, y, z) to electrically isolate it.

I recently just got my machine, so no long term success or failures, but… Last night while trying to set up a milling operation when I went to touch off the probe, as it came down in Z it stopped for a second once it made contact and then decided to continue downward, crunching into the touch plate. I quickly slapped the “big red button” to save the day. Then, being gun shy, I tried again holding the touch plate up in the air so I could stop things before poking more holes in my touch plate. It did the same thing again!, Yes, I did have the magnet attached, BUT, like Eric and Tyson just suggested, I have been putting the magnet on the collet nut, not the tool! Hmmm
I’ll try again in a few minutes when I get out to the shop and see if that makes any difference.

Steve

addendum: Crazy thought; I had been trying to use Fusion 360 and broke down and took Eric’s advice and purchased Vcarve yesterday. When my probe crash happened I had a gcode loaded into Mach4 from Vcarve. Surely no connection!? Hadn’t ever happened with a gcode loaded from Fusion.

I have only used vcarve for my gcode and always use the touch plate for all three axis. Not one problem encountered except for that one time at band camp when I put the magnet on the collet. So I don’t think there is a correlation between the gcode and the TP

The crash definitely came from the Gcode! My son who has been CNC’ing quite some time came over to help me out. When we simply opened Mach4, homed and touch plated, no harm no foul. As soon as we entered the Gcode produced by Vcarve it added an absolutely crazy offset in the z axis of some 800,000,000 trillion! Which made it try and drive thru to China!!
Knowing how to read Gcode, Zac went thru it line by line and edited several things, deleted what he called unnecessary crap and the program ran perfectly without any issues. Oops, there was one other thing we had to do, turn off the soft limits; it kept throwing a code of exceeding z limits, which it wasn’t doing. Anyhoo, the simple program I was trying to make; pocketing and slotting holes in 2 x 4’s so I can bolt them onto the side of the aluminum extrusions on the Avid machine and make them adjustable so I can make them flush with the top of the bed of the machine; worked slick as snot after Zac worked it over. Obviously, I need to get better acquainted with Vcarve and toolpaths as what we did was waaaay to much work for me! Once he fixed the code, it only took about 4 minutes apiece to put 4 pockets and slots in the 2 x 4’s. So sweet to watch it flawlessly cut the first thing on my machine.

Steve

1 Like

They’re available here. Not all of the updates include updates to the Mach 4 setup. I think version 2.3.2 was the one that fixed some of the issues I was seeing.

1 Like

I stand corrected. I never had a error fromvcarve to Mach, You seem to have a problem I never encountered. Sorry if I assumed things. Glad you got it tracked down. Carve on my friend!!