Help setting up Mach 4 on Windows 11 via Parallels

Trying to set up Mach 4 through Parallels on a Mac. I know others have done it and I didn’t think it would be this difficult. I ran through the SCU app to setup and I thought I was all set. Mach 4 isn’t reading the ESS. I’m kind of at a loss at this point. I tried resetting everything and starting from scratch but that hasn’t helped. Any windows guru want to lend a brother a hand? Any help is much appreciated. Machine is built and I would love to see it in action. Thanks!

Hi, Why are you trying to do it this way? You really want to have Mach 4 run it’s best, and running it in the emulator is going to be pretty slow. Do you have an intel based Mac? Run Boot Camp and make a dedicated windows partition and install Windows on that partition to dual boot into it. You’ll be much better off doing this. If you have an M1/M2 Mac, then that won’t work, and I’d recommend getting a cheap NUC PC over running it in Parallels.

(PS: I worked at Apple for 13 years.)

Hey Corbin,

No excuse other than I have no idea what I’m doing with Windows. I’ve been using Mac ios for all my design and music for the last 20 yrs. I’ll get a partition for windows going since it is an intel mac i have dedicated for the cnc. I’ll let you know how I make out with setup after that. Thanks for the input. I appreciate the videos you’ve put up too. I’m trying to get the S30C up and running. Can’t even get the stepper motors working lol.

No issues communicating after reinstalling windows with a partition. Thanks for the input. Windows definitely seems to run a lot smoother/quicker as well.

1 Like

Cool - that’s definitely the way to do it. I put Windows on an old Intel Mac so I can run VCarve. I also run it on my CNC’s computer when I’m not actually cutting, and use Microsoft Remote Desktop to remote into it from my Mac.

Hey Corbin, I loaded your ATC screen set and made the file and pin changes you walked through in your video. I’m having an issue with not being able to use the drawbar button on the ATC tool screen. When I click it to open it flashes yellow/red but no response at the spindle. Any ideas where to check on my setup?

It has to be something with either the pin mapping setup in Mach 4 / ESS, or something in your physical wiring that isn’t right. I’d go back again and check/follow all the wiring setup for your spindle and make sure everything is setup on the right pins and inputs – both in the Avid CNC control box, and in the Pin setup in Mach 4 / ESS. Or, your 20v power regulator isn’t wired right (the thing the relay uses to power the air solenoid).

If you want to eliminate a variable, you can load up the CNC Depot screen set and see if it works for you there.

I’ll run back through everything later this week. Is there any chance that a low psi could be an issue? I have it set to 105 but not sure how accurate that is at the machine itself. Does this sound plausible with the Mach 4 reaction I’m getting (yellow/red flashing)? Just trying to cover my bases.

No, the flashing is just the setting on the button; it means it is “open”.

I figured out where I went wrong. Pretty stupid mistake. I thought the air relay was receiving voltage from the ESS board, not realizing it’s powered by the driver on the spindle side. I had spindle power shut off when I was trying to open the drawbar. Pretty satisfying to hear the drawbar activate. Running through the break-in cycle on the spindle and hopefully cutting soon. Thanks for your help.

Ah yeah! The ESS board just provides the signal. Glad you got it solved!