Laser Rastering going in the wrong direction

Hello all, I’m hoping this is something others have run into before.

I’ve recently added a PLH3D-XT-50 from opt lasers to my pro 6060 machine. Everything is working well in vector mode, but I’m having a weird problem trying to get things working for rastering images. The short version is that when attempting to raster an image, instead of the patter I expect I am getting one that has been distorted in the X axis, although the Y axis looks fine. Instead of the laser head moving in the +X axis I expected it is going in -x. Also the image seems to be scaled based on the FEEDRATE I have set in the m2001.

For example when using the inch version of the quick cal pattern Jim Neeb graciously shared at Public CNC Docs - Google Drive. Thanks to him for the awesome documentation he has made about many avid topics.

for speeds < ~200IPM I am getting an image smaller than the one inch expected, and for higher speeds it gets progressively wider.

Here are some of the things I’ve tried, but I’m still scratching my head here.

I’ve tried adjusting the __Adjust_Raster_Image_Alignment and __Vector_Speed_Comp files to have all zeros, as well as disabling compensation entirely. I see that if I put a bogusly large value in the alignment file it does shift things over so it is having an effect, but it is still going in the wrong direction.

I’ve tried a fresh install of mach4, both the avid packaged one, and a non avid one following the instructions at FAQ Mach4 I get the same result. This means using ESS plugin v298 and 285.

I’ve tried various values of IMAGE_STARTING_CORNER. The head consistently moves in the opposite X direction from what I would expect based on the value. It also remains distorted in size.

I’ve tried setting COMP_FOR_ACCEL_DIST_X=0. I don’t think I would have noticed if it was off by the amount of distance for the servo to accelerate, so it may have had a tiny change, but things seem the same.

From some googling it sounds like this may be related to the “x-y velocity PWM” signal setting in the HC tab, but I’ve got it unchecked like in the instructions. Not really sure if there is anything else here to play with since I don’t have a plasma cutter.

Also there is nothing obviously wrong looking in the log file.

Thanks for any thoughts.

Lets start with the raster direction first (I have to think about the other one longer).

Check to make sure none of your motors have the “reverse” checkbox checked in the motors configuration in mach4. Those should never be set, but they have been in some of the AVID builds. It doesn’t affect any normal Gcode operations, but it will get picked up by the raster routine (I don’t know why, but it does).


Thank you so much for looking at this.

At the moment I can’t confirm this was the problem because I have erased the computer and reinstalled everything. The good news is that things do seem to be working properly with the re installation.

I do have a backup, so I’ll try to verify if it was clicked, it certainly sounds like it matches the symptoms, but super weird that the setting would only be used by raster operations.

It is, but at least it was your X axis. I discovered in on my machine when only one of my Y motors was like this, so both ends of the gantry wanted to go in opposite direction. That was a bit disturbing.

Wow, that must have been both frightening and hard to debug.

A bit of a long shot, but do you know of any settings that might make it ignore the macro:


It seems to be ignored, and I can imagine it being effected by something like constant velocity vs exact stop.

Luckily I can just set it in the motor setup dialog, so it isn’t really that important to fix. Especially since I dont expect to be rastering all that often.

No, but I don’t think I have actually tested that capability for quite some time. I think it was released around ESS273 or so. I’m testing a new release today so I better make sure its still working.

I always use CV, is yours on exact stop?

You are right, it is no longer working. I will feed that back to Warp 9. Thanks for letting me know.

Thanks for confirming this. It sounds like I can try running an earlier version in the even that this bugs me too much.

Also thanks for making the instructions on how to set it up in the first place. I don’t think I’d have it working at all without your examples.

Don’t bother looking for it in an older version. Looks like the code I tested didn’t make it into a production build :-(. It was an accident, so they are working on incorporating it into the next ESS build now.

Thanks for looking into it.

I don’t think it matters too much, but do you have any idea why the want you to specify acceleration as a percentage? I would have thought just specifying a desired acceleration would be better.

My guess is it save them from having imperial and metric flavors of basically the same thing.

I don’t recall, your assumption is probably right.