Machine not cutting accurately

Hello all, I am an experienced carpenter and woodworker, but pretty new to the CNC world. I have an avid Pro 4x8 that has probably 100 hours of run time on it.

I cut out a stool on it about 6 weeks ago where the legs fit into blind mortises in the bottom of the seat. The machine cut them very accurately and the legs fit wonderfully. I tried to make another stool last week and mortises were undersized. I didn’t measure how much, I just set the project aside. This evening I cut out a cabinet upright with several dados and they too were undersized by about .05".

Since the first stool was made, I’ve been running the machine almost daily cutting out Christmas signs and framing parts for my camper vans. I’ve been conservative with my feeds and speeds most of the time, really not trying to strain the machine. Most of that estimated 100 hours has been in the last 6 weeks.

With the machine on, I grabbed the spindle and pushed back and forth on the Y axis with a fair bit of pressure and noticed just a smidge of play. Its hard to tell exactly how much, probably less than 1/16". Where should I start? do these machines lose accuracy with time? Pease enlighten me.

A few things to note: I’ve been regularly greasing the machine, the bits have been sharp, the work piece was properly secured, the inaccuracy is a consistent .05 (±.003), I re-leveled the table and set the limit switches again (they were out slightly from assembly) about 6 weeks ago, not long after I made the last stool with accurate mortices. I double checked the software side of things and they appear to be as they should.

Thank you

Have you tried leveling, squaring and tramming the machine per the Avid instructions?(Machine Calibration) I am using the Avid tramming mount, which saves a lot of time. But I still find it necessary to tram (using an Edge Technology trammer) every half dozen jobs or so to get best results.

Also, do you notice the error in both X and Y dimensions?

I have squared and leveled the machine pretty recently but havent trammed it since I assembled it. Do you think that would affect the accuracy that much? Thanks for your input

Hard to say - .05” is a fairly substantial error. As you know, if not properly trammed, the spindle will not be exactly perpendicular to the spoilboard, and therefore, the tip of the router bit will be offset in the direction of tilt relative to where it should be (and at the wrong Z position as well). Definitely worth your time to check this. If you use a double-indicator tramming tool, and have the Avid tramming mount, you can do this fairly quickly after a bit of practice. You can get a set of feeler gauges inexpensively on Amazon, for example, to use as shims.

heck if you think it is out of tram by .050 you could just put a bit in it and check it with a small machinist square and see that.


Might just need wear components replaced. I didn’t see any mention of new drive spindles, belts or bearings.

That doesn’t sound right. Depending on how much use this has it could be worn pinion gears (the gears that pull the machine down the rack)

But rather than guess a lot I’d recommend you check out the troubleshooting guide:

If you scroll down there’s a section that addresses mechanical things you can check.

If that doesn’t lead you to the issue definitely get in touch with support. They’re awesome and will help you figure out what you need. (just click on “contact” on that troubleshooting page)

1 Like

I will definitely check the tram. Thank you!

I have replaced these. What would indicate that they need to be replaced? (besides it losing accuracy)

Thank you! I’ll give that a look.

Has there been a solution to this issue?

I was doing a maintenance and decided to check my machine for its cutting accuracy, more of a curiosity thing.

Using a tape measure and traveling the whole length and width of the machine I had an error of about .0625. but that was using a tape measure. Not a great item for accuracy but enough to get one started.

Cutting a test pattern . 4" square and measuring with 2 different calipers I am out by 0.033 in both x and y axis.
First thought was an offset somewhere. So looking at mach4 and vcarve there isn’t any that I can see.

It’s odd how both directions are out and the same amount.

As part of my troubleshooting I did record my motor steps /unit in mach. X was set to 2040
Y motors were 2038.
Mach 4 has a built in step calculator so putting in what I said to move and what the machine actually moved I get a new value.

Weird thing is. Even if I put those values in. The machine does the same thing. Still has a .033 error.

I was expecting the error to at least grow in either direction or shrink to tell me whether I’m on the right path.

does anyone have any thoughts on what to try?

I racked my brain over it for too long. I did measure the actual size of the bits I am using and they are a bit under .25, so I adjusted for that which took some of the error out. Since the error was still happening and consistent, I just played with the pocket allowance and allowance offset (for profile cuts) in Vcarve till it was elliminated. I wrote a note of how much to offset so I dont forget. Problem solved for now!

1 Like