Weird loss of steps?

Hi.

I have a 4ft x 10ft Pro Avid CNC and have been using it almost daily for the last 2 years or so, it has the NEMA 34 motors and is running with the Avid version of Mach 4.
Today I was cutting a job with 4 identical parts, the first operation was to cut a shallow pocket in each part using a 1/4" ballnose bit.
The first three pockets cut as expected, however it cut the 4th pocket with plus125mm on the X axis than where it should have e.g. the pocket was 125mm further to the right than it should have been.
Luckily I spotted it and stopped the program and then commanded the machine to go to X-Y zero and it ended up 125mm away on X postive from the true zero.
There were no mechanical issues when cutting and I didn’t see any software glitches, but the screen is slightly behind me when I am at the CNC,
The position of the cut was fine on the Y axis and the depth of the pocket it cut was also fine on the Z axis, so only the X axis was affected.
Anyone have any ideas what could have caused this and what I should check, it’s got me stumped and also concerned now as if I hadn’t spotted it I would have lost all 4 components being cut and now I will also worry when cutting more :frowning:

Thanks
Gus

Hey Gus, welcome to the forum!

Have you checked the drive components? I would mainly disassemble the X-axis R&P drive and inspect the drive spindle gear and belt. There are wear items there to consider.

Aside from that, don’t hesitate to reach out to the company.

Thanks David.

Inspecting the R&P gears there is some wear there but not enough I suspect to account for it getting that far out over the space of approx 16" or so of travel.
I do have a spares kit so will replace the gears and the belts and see how it goes.

Thanks
Gus

Hey Gus just curious did you figure out your problem?

Jeff

Hi Jeff.

I can’t say for sure 100% yet, or at least my confidence level hasn’t quite gotten back to where it was before.
I replaced all of the drive spindle gears and two of the belts (not sure why you only get two belts in the spares kit) and for sure the machine is quieter when moving, especially on the Y and X axis.
I also updated all of the software e.g. V Carve pro, and MACH 4 to the latest versions.
I also checked the electrical connection to the machine and have re-routed the main power cable to alleviate any potential strain that was on the plug as it looked like it could be under load on the pins the way it was, I also saw something about maybe power surges/spikes may cause an issue so I installed an IP54 Safety Power Board which is supposed to have surge protection with it.
I also changed out the two USB thumb drives that was using to transfer files from the house to the shed computer, they were quite old and had been well used and one of them had actually been through the washing machine once but still worked.
So far I did have a smaller but similar issue after changing the R&P items so am convinced that it wasn’t a mechanical issue, but am glad that I changed them as the machine sounds far smoother now than it did.
I am hopeful that the combination of updating the software, improving the power supply and changing the USB thumb drives has solved it, but time will tell.

Cheers
Gus

Update.

Well after doing all of the above the machine just stopped moving again today, the gcode froze and the spindle kept on spinning.
Luckily this time I was able to catch a glimpse of the computer screen and saw that at the same time as this happened I had a small screen pop up from NVidea, some notification about updated drivers or something.
Now, when I first set the machine up when new I remember running something from AVID that checked the settings on the computer and that disabled most other things from running/updating automatically, but just recently I installed a new graphics card and obviously the ‘NVidea Experience’ program was automatically installed as well and was free to do it’s thing and this may have been causing the issues.
I have now disabled all notifications from NVidea Experience and will see how I go, but will likely see if I can find the info on running the AVID checker again to make sure I haven’y missed something else.
Just something to think about if you ever have any similar issues.

Cheers
Gus

Motion issues are commonly traced back to PC configuration issues. See Troubleshooting help needed

You can find the Tuning steps in the docs at Mach4 Software Setup - CNC Software

You might also do a web search for how to determine which items automatically startup with Windows, and how to disable the ones you don’t want/need (looking at you, OneDrive).

Thanks David.

Yes I found that I already had the Avid CNC - SCU Application on my desktop from the initial install so just ran it again, the GPU was flagged as not meeting specs, rerunning the software sorted that out so hopefully all will be good now.
I will also do as you suggest and check the start up and see what is auto loading.

Cheers
Gus

Hello! I’ll do my best to help you troubleshoot the issue with your CNC machine.

Since the issue only affected the X-axis and not the Y or Z axes, it’s likely related to the X-axis motion control. Here are a few things you can check to identify the problem:

  1. Loose or Faulty Connections: Check all the connections related to the X-axis, including motor cables, limit switches, and encoder cables. A loose connection can cause intermittent issues with positioning.
  2. Belt Tension and Pulleys: Ensure that the belts driving the X-axis are properly tensioned and securely attached to the pulleys. Loose belts can result in unexpected movements.
  3. Motor Calibration and Steps per Unit: It’s possible that the motor settings for the X-axis got altered or corrupted. Check the motor calibration settings in Mach 4 and ensure that the steps per unit are accurate for the X-axis.
  4. Mechanical Bindings: Manually move the X-axis along its full range to check for any physical obstructions or binding points. Make sure the axis moves smoothly without any resistance.
  5. Software Configuration: Review the settings in Mach 4 specific to the X-axis. Check for any discrepancies compared to the Y and Z axes. Look for any settings related to backlash compensation or soft limits that might be affecting the X-axis.
  6. Limit Switches: Verify that the X-axis limit switches are functioning correctly. If they are not triggering properly, it could lead to incorrect positioning.
  7. EMI Interference: Electromagnetic interference (EMI) can sometimes cause erratic behavior in CNC machines. Check if any new electronic devices have been introduced near the CNC machine that might be causing interference.
  8. Machine Geometry Calibration: Check the machine’s geometry calibration and make sure it is accurate. Incorrect calibration can lead to positioning errors.
  9. Software Updates or Glitches: Although you mentioned that you didn’t notice any software glitches, it’s still worth checking if there have been any updates or recent changes that might have affected the X-axis behavior.
  10. CNC Controller or Motor Driver Issues: There could be a problem with the CNC controller or the motor driver specifically for the X-axis. If all else fails, it might be worth contacting the manufacturer or a professional technician to inspect these components.

Since the issue occurred sporadically and not consistently, it can be a bit challenging to pinpoint the exact cause. Be sure to double-check everything before running any critical jobs, and consider running some test cuts to monitor the performance of the X-axis.

If you are unsure about any specific aspect of the troubleshooting process, it’s best to seek help from a qualified CNC technician or the manufacturer of the CNC machine. They will have more in-depth knowledge of the machine and can offer hands-on assistance if needed.

** UPDATE **
Well after doing all of the above I was still getting the odd/random issue with for example, the spindle would just stop moving but would continue to rotate and would also lose it’s position ever so slightly.
I had also noticed that on occasion when starting up the machine and going to home it, one of the axis would just keep going and run in to the stops, I had put this down to my xbox controller being dusty and would blow it out, however over time I realised that this wasn’t working and so got a new controller, but again it would randomly do the same thing. I then noticed on the forum that other folks were having a similar issue with their machines.
Well, happy to report that since changing the RJ45 Ethernet cable to a shielded cable and ensuring the routing of the cable was as clear of other cables and especially the dust extraction system I have not had any issues in the last few weeks (hope I haven’t jinxed myself here hahaha) It’s to the point now that my confidence in the machine doing what I ask it to do has recovered.
So, for those that are having issues a shielded ethernet cable is a quick and easy way to see if that will resolve your issues.

Cheers
Gus

This is kind of late for the thread, but when you are installing a new NVidia driver, you should have the option to install just the driver or the driver with the whole NVidia Experience. I would suggest just installing the driver. Then you won’t have another process running in the background to muck up things.

Thanks Garth.
Yes, that is a very valid point, and as noted above I did not do that and had to go back and disable the Nvidea experience manually.

Cheers
Gus