Skipping a step

I think my machine is skipping a step. After I home the machine and start running the first toolpath about 1/3 of the way through the first tool path I get a quick clunk and then my cuts are off exclusively along the x axis. I think the clunk is coming from the y stepper motors.
It generally happens only once after being homed but then it may not happen again. This is costing me a lot of material. I’m having to factor in one sheet of material of waste for each job just to account for this.
I have checked the tightness of the screws along all racks.

I would greatly appreciate any thoughts but if you give one it would be awesome if you could as to elaborate on how to diagnose/execute your solution.

Many Thanks

I just upgraded my controller PC in the hope that it would fix this problem. I haven’t had enough time with the new PC to tell whether it solved the problem.

What kind of PC do you run Mach4 on? Windows 10 or 11, how much RAM?

Do you know whether it tends to happen on a long move (linear or arc) or on a quick series of short moves (linear interpolated shape)?

Another option is a short somewhere. @wbest had a cable that got chewed through and caused an intermittent issue.

If there is a clunk then something is defintly wrong.

Check the teeth on your gears on the Y-Axis.

Check the cables on the X and Z…they can rub and wear if you don’t get them installed correctly.

I did buy a new machine running windows 11, 8gb RAM, I7 processor. and I5 should be more than sufficient.

You should plug the network cable directly from you machine to the CNC control. Don’t plug into a switch or router.

If you got all that, reach out to the Avid folks and they can usually make some really good troubleshooting recommendations.


1 Like

Long moves generally. I got it to do it upon startup today. I ran some g-code through it on Mach4 MDI after homing it. I ran it between x45 y95 and back to x1y1 home a couple times. I heard the clunk/clank right before it got to xy home in the front left corner. It sounds like it comes from the left side of the table if you are facing the spindle. So far when I have noticed it occurs in the front half of the machine.
I gambled and loaded material on the spoil board with 5 toolpaths and ran it flawlessly zero issue.
I’m running a dedicated hp laptop with 16GB Ram i7, 500gb SSD, windows 11. Bought it brand new in 2021 for the specific purpose of leaving it attached to cnc.
All the gears have teeth and I ordered a parts kit from avid. I’m going to replace belts and gears and do a closer inspection once its apart. Keep the suggestions coming fellas. I appreciate it.

Thinking out loud here, … Is it possible there is a bit of a parallelogram distortion going on with the frame so that after the homing is done there is a small amount of binding between left-side rails and right-side rails? One quick way to check this is to run a tape measure from the very front left corner to the very back right corner and write that number down. The measure across the diagonally opposite corners and make sure they match or are pretty close, say 1/8in or less)…

After checking that and making sure the frame is square, home the machine and check that the gantry is reasonably perpendicular to the left and right sides of the machine. We’re looking for groose errors so measure from the front edge of the machine on the right side to the gantry on the right side and then repeat with the left side.

1 Like

Also thinking out loud: Would this help? Before homing, jog down near zero, then do small incremental steps and see how many steps it takes between when the right and left Y proximity sensors light up?


Going to give this a try.

Going to give this a try. I did the alignment toolpath supplied by avid. The 4 holes with .25" diameter pins and check for square. I was dead nutz or so small a margin of error it could not be picked up by my eyes. (Perfect uncorrected vision) Lucky me lol.

Ok just walking out to the garage and using a speed square, I checked the rear corners of the frame. They appear to be square. Now assuming the machine has not been bumped or moved on its own, but where the gantry is resting right now, the left side (if facing the machine) appears to be 1/8" forward of the right. When I home the machine, the left limit switch goes off about 1/10 of one second sooner than the right. Basically indicating the left side is just in front of the right. Thoughts? Fixes?

After taking the measurements above I went to the limit switch screws. I’m not sure what there technical term is but just know they are the screws at the front of the machine that the green limit switch detects to stop the gantry from rolling off the front of the machine. Also to home the machine. Using a caliper, The left front appears to be .030 forward (moving from the front of the machine to the back or y+ direction) of the right one.
I’m going to adjust them to be equal and see where we are at.

Just understand that moving those screws (sensor flags) will change the relationship to the X-axis in terms of square-ness.

Another test is to back out the Y rack and pinion tension screws until the gears don’t touch then manually push the gantry up to the front bumpers, forcing each riser against the bumper intentionally, then let go all at once. What you’re looking for is if either side springs back farther than the other (more than 1/8"). If so, the gantry resting position is significantly out of square and what you’ve been running has had a lot of tension on it to remain square after homing. All this is assuming your bumpers are roughly even and not a mix of short one and longer one or something out of the ordinary. The solution, if required, is to shim the gantry extrusion which has been discussed on this forum elsewhere.

I have had a similar issue as yours. I use Clearpath servos so I do not loose position but get a random and infrequent clunk on all three axes. My system performed flawlessly for about 12 months before developing this problem. I think I have traced the issue back to the ESS motion controller but I won’t know for sure until I install the new one I have on order. Using the Clearpath internal scope function I can clearly see 100 msec drop outs in the step signal coming from the ESS which coincide with the clunks.

Update. I may have located the problem. I was running the gantry back and forth along the y axis to watch and listen for the clunk. I got it almost right away and then nothing but smooth operation. I kept running the machine back and forth.

Side note:
I adjust the proximity censor on the right front to match the left front. I used a caliper and got them dead even. I then homed the machine. Both side of the gantry hit the limit switches at the same time. Perfect.

Back to the original issue. I noticed one difference from the right motor to the left motor and that was visible play. The right one was solid. Acceleration to stop it was solid. The left one revved up and down like a dragster when it accelerated during jog or running manually entered g-code. By revved up i mean I could see motion up and down on the red tensioner spring. Not like a little either. Clearly visible once you payed attention too it. Right side motor, rock solid.
So I turned the left motor tensioner bolt on the spring half a turn and ran some more g-code. No clunk and less movement up and down. Another quarter turn and now its very smooth operation. By the looks of it, the problem could have been not enough tension on the motor assembly giving it play, a lot of play, on the track. So far, so good. No, I did not overtighten it. The turn on the tensioner bolt was about 3/4 turn.
I’m hoping this the fix. If not I’ll be back.

another side note:
After homing the machine and making all the adjustments, when the gantry backs off after homing it is totally square.

Thanks for all the input. All the ideas really made me focus on details and that is inevitability what caused me to see the motor housing movement.


@minnow , … That is awesome! I hope it stays fixed for you! :slight_smile: