Troubleshooting help needed

Hey folks. I finally finished getting my system setup and physically things seem great, but I’m running into issues and can’t figure it out.

I’m trying to do the ‘tool tray’ tutorial and seemingly at various random points during the actual cutting, where the cutting head is vs where the software thinks it is goes completely out of sync and it starts destroying the project. The individual cutting paths appear to be fine, it’s only when it’s traveling between one cut point and another that things go haywire. I’ve attached the gcode and the project file itself as well in case that’s helpful. I’ve tried both merged and separate toolpaths in the gcode (merged got farther before it screwed up). (228.6 KB)

For example - in the latest run here’s the screenshot of where the Mach 4 thinks the tool head is:

and here is where the tool ACTUALLY is (mark is showing where it should be):

I saw this a lot when I first built my machine using pre-made electronics. It turned out to be caused by several loose electrical connections in the AVID boxes.

The most dramatic issue was with the mains switch where one of the 240V supply wires was not screwed down. The black “neutral” wire in the picture came out when I pulled on it.

After refitting it, I haven’t had the problem.

Might be PC resource related. I see you have a browser open and Wifi connected, which are not recommended. Maybe you just have that active for documenting it? If it’s only messing up while traveling between cut points, you could try reducing your Rapid Rate to, say, 50% (300) to determine if that helps. For such a small footprint it won’t have much impact on your runtime.

Your cut quality is nice

Have you checked in with support? as others have said this looks like it could be a PC setup issue.

Fair to mention. Windows doesn’t show all relevant details in the systray though, so the physical link is hidden from view. The laptop used to run the Mach4 software meets (display resolution) or exceeds by double everything else - (16gb memory, 4core/8thread, etc), is directly connected, and the only thing else I run is a web browser that manages things like music via pandora, and any CNC related stuff I’m doing (like this forum page) - 2 to 3 tabs at most because I try to keep it lean for the CNC software. I’ll try it again this afternoon with literally nothing else running, to be absolutely sure.

And yeah, the cut quality itself is excellent, I’d expect the circles to be the worst part if it was some sort of resource or communication problem because you can see the gcode commands screaming by like crazy - but the circles are flawless. I’ll definitely check out the rapid travel speed, I left as many things as I could at default while setting up the machine profile.

Here’s a short video showing the machine and the setup - August 7, 2023 - YouTube (the two pieces of wood visible in the video were spoilboard for each other, I was not cutting with my workpiece directly on the frame)

This wouldn’t surprise me too much, the packing was great when it arrived but a number of the boxes were a bit beat up externally, so a loose connection wouldn’t be shocking.

I’ll check in with them next, wanted to stop by the forums first to make sure I wasn’t making an obvious end-user mistake.

Just consider that Mach4 works in conjunction with hardware (the ESS) a little different from your common desktop apps and it needs a little…pampering. On-time and in-sequence command execution is absolutely crucial. The included SCU application helps disable and optimize some system-controllable elements. The ESS manufacturer recommends the below, found at Documentation: ESS (Ethernet SmoothStepper)

Warp9: While you are running Mach and your CNC system, we recommend that you refrain from browsing the internet, gaming or streaming music or videos. This can cause your computer to take too much time away from Mach which could cause lost communications with your ESS (which can ruin your project).

The other benefit of committing the control PC to Mach4 indefinitely: If it’s not online, you can disable all anti-virus and other external safeties which may interrupt CNC operation.

Alright, I’ll try it again this afternoon with literally nothing else going. If that solves it, great.

If it does happen to come up again at the same point (traveling from cut to cut), then what?

I think if that happens again definitely get in touch with support.

Make sure you put your g code in a folder on the hard drive and not running it from the USB in fact remove the USB after transfer (ask me how i know) I’ve had a few funny things happen :roll_eyes:

The gcode gets loaded from a network share, hadn’t expected any problems since it reads the whole thing (only 180kb) before the project starts, but it’s another thing worth trying - thanks

Just tried again. Same code file as before (merged tool path version). File loaded from local directory (desktop). Bluetooth off. Wi-Fi off. All other programs closed (I don’t run any sort of antivirus, only the built-in Windows Defender). Machine freshly homed, work space zeroed to ‘front left corner’ as usual. Everything moving and behaving as expected during position jogging to get it near to the workspace.

Very first travel command from work zero to the first cut did not move far enough.

Green is work zero, blue is where it should be and where the program thinks it is, red is where the tool actually is.

Time to get in touch with official support, I guess.

Problem solved. PEBKAC.

I had forgotten to re-run the windows tuning detail after running windows updates. I had done it once months back before I had the machine finished and completely forgot about it. This resolved the problems.

1 Like