New and fun problem

I seem to not be able to get my machine back to working great again. I had a bunch of cabinet parts to cut. Everything is dimensionally perfect and square.
The dadoes are good as well. The rabbits on the edges are the new problem. Anything cut in the x direction is dimensionally fine. But obviously would use y to get to the start point of each.

On the y though, every rabbit that was on the left side of a part was not cut wide enough. They are supposed to be .36in and the ones on the right are perfect. The left ones are about .28 to .32. the x direction would be the reason it didn’t go to the width it was supposed to.

I have gone through my design thinking that my values didn’t change correctly when changing stock thickness. I measured each one and they are all .36in. this isn’t depth of cut on the ply, it is xy direction that I’m working on. I’m using fusion for design and parameters for the dadoes and rabbits. All calculates fine.

After checking that, I thought it could have skipped steps, but I was cutting at a low rate because I do not trust this machine any longer and have been extra careful to pay attention to what is happening. If it were skipped, I would expect other features to be incorrect and everything, including the final cutout are all correct dimensions.

I tested to see if I could get the machine to skip by moving the gantry and attempting to stop it. I couldn’t in both directions. I was pushed by it while trying with the y, so definitely not skipping.

What in the world could possibly cause this issue? I’m at a loss and starting to hate this thing. I have no faith in this ever getting any better now and can’t trust that it will do what it is told to do. I’m regretting this machine more and more after every use.

Did you check the tensioner bolt on that side of the R&P plate? Did it freeze by the threads catch and keep the pinion above the rack?

Does that side of the gantry move when you have the motors on and you push and pull it?

All signs the tensioner bolt’s threads are caught.

Just a guess, … I wonder if it is worth loading the G-Code into a 3’rd party tool, like one of the free web-based ones and measure the difference between the edges of the actual path and then subtracting cutter diameter? I only mention this as Fusion has tons and tons of settings and it is possible accidentally get one set that persists and not set it until doing this kind of analysis?

I am in no way affiliated with these guys, but I have used this one before and find it quite handy. You can point it at the G-Code file on your local machine and instantly be looking at the motion profile withouth there being any odd interpretations of the machine that created it.

Don’t know if that helps or not, just something to try to help rule out possible contributors to the problem.

1 Like

I was making some table legs with a treadle in-between, I drew the profile for the tenon and used the mirror tool to create the other end of it. Well I messed up 3 boards trying to get that part . Each time I cut, one end would be smaller that the other. It was because it was mirrored, when the profile cut was run it cut outside one end and inside on the other. Are any of your rabbits mirrored?


I did not use mirror on anything. I did use rectangle pattern on bore features and that was a different tool and output. I do use a tool called MapBoards pro to grab all the parts and nest them on sheets. It creates copies of the bodies and I went through each of those to make sure that the measurements were correct.
This very well could be an issue with fusion posting wrong. That mirror bug sounds like a nightmare.

I have not verified the path in another tool. ncviewer is something I use to verify things on complex parts if I want to see how it is read before running. I will have to load it in there and double check this too. It is the most straight forward and simple kind of cut I can think of running. Straight lines only.

The fact that everything but those features came out perfect is the thing confusing me at this point. How could it be off on a portion that was cut BEFORE the final cutout and the final cutout be correct? No tool change and all of the ops are in the same output.

I will check in ncviewer and see if anything is different

1 Like

Well, I tried several external viewers to see if I could find anything. NCViewer shows the exact same movement on the toolpaths for each of them. I cannot verify it exactly because measuring is not possible.
I tried camotics and it did not help much either. It does seem as though the output is correct.

@subnoize I honestly do not think that the issue you described has occured. When I was replacing the pinions and belts, I worked on what you described several times to try and prevent that from happening and have not seen the issue arise. I know this is not related but, the right pinions belt on the Y is not centered on the it. The belt is sitting on the edge. Almost close enough to rub. It does not rub but, it is close.
This pinion was the only one actually worn down before replacing and I thought that it is possible for something to be slightly turned out in a direction that would cause the uneven wearing and set the position of the belt towards a side instead of centered. I am not sure if that is an actual issue though.

I guess that the only way for me to really try to figure this out is to create a test piece with a bunch of pockets in different directions at set intervals and widths/lengths that I can run and measure. Maybe I can find out what is happening with that. I am not sure how much the total upgrade would cost to replace everything with servos and switch to another control software. I am not a fan of mach in any flavor. Having feedback on position would be nice too. Maybe I can get everything functioning well without doing this. I wonder if the rack and pinion setup itself is inherently trash. I know that it is probably the least expensive for the size of the machine I have though.

The last thread I started was about getting my circles back. Now this. I just want to get back to working and I have got to figure out what is happening.

1 Like

ok. I have around 20 parts that were cut. I found a couple from a batch that are wildly different from the rest of the errors I see. Out profiles are all cut correctly. However, and I am not sure of the orientation of the two parts originally, these two parts are the same measurements in design for everything. They were oriented differently on each and all of the widths of the rabitts are supposed to be .36in. one of them is at .16 on one end and .2 at the other. Something is for sure sticking or skipping in some way. I cannot understand how it would then correct itself and give the final outer dimensions that they were supposed to be.
I guess the rabitts were cut wider to account for the cutout and any offset that occurred could cut fine on the last step. That then would be the potential way that the rabbits are wrong and the outer measurements are correct.

How would you test to see if things are skipping? @subnoize I now think that your description may be the actual issue. I will do more testing to see. I swear, i could not get the gantry to stall or skip with my weight. It pushed me across the floor as I moved it.

one more test. Instead of trying to push against the gantry movement at start of movement and just trying to stop it. I started to move it and then pushed against each moving part quickly with a decent amount of force and was able to get each of the motors to skip. Once at full speed it will push through without issue. As it accelerates seems to be the spot where I can get it to skip.

Threads do not seem to be getting caught. Maybe I just need to tighten the bolts more. I tried to put just enough pressure so that I could still manually move the plate when pushing against it. I was told previously to allow movement and that pinions will wear earlier if too tight. Maybe I just have to tighten them and live with the wear.

I just spent the last hour moving my racks on the y because I kept getting a message stating that a motor was not able to back off the sensor. I moved them a little closer to the front and made sure they were exactly the same distance from the front on each side. I figured this was going to solve that issue and possibly get rid of any racking if it existed.
I never had that message until mach4. After doing all of that, I still get the message.

Does anyone else see that message when homing Y? Is this a sign of something else I should check? Maybe whatever is causing this is related to my other issues.

1 Like
Unfortunately it sounds like you have gotten off into the weeds somewhat. Generally the problems I have seen when got getting things turning out as expected are not from software, but from hardware. You have to be methodical when chasing down a mechanical issue to eliminate one part of the chain at a time.  The learning curve for CNC is huge, there are many many things that can effect your parts.  There is no reason not to trust your machine.  NEMA 23 are plenty to run this machine...missed steps should not be part of your worries unless you have something assembled or misaligned.  Avid would know for sure but I assume the machine is able to output 60-80lbs of force on the bit when cutting...if you need more than that, something ain't right. 
Take your machine and park it, take the collet off so it is just the threaded shank of the spindle...make sure power is off to the spindle, now grab the shank and shake the shit out of it...there should be no movement. 

Make some test cuts and measure them. If X is working fine then concentrate on the Y. Are your test cuts coming out correctly? If so then maybe you are having hold down issues with your work. I’m guessing you have something loose in the machine causing you excessive backlash…like a belt pinion…this would give you the variations you are seeing. When the machine moves in a single direction for a long cut everything turns out fine since the slack is taken up for the entire cut, but as soon as the machine changes direction you are losing accuracy because there is excessive backlash somewhere. This could also trick you into thinking you are losing steps.

I just spent the last hour moving my racks on the y because I kept getting a message stating that a motor was not able to back off the sensor. I moved them a little closer to the front and made sure they were exactly the same distance from the front on each side. I figured this was going to solve that issue and possibly get rid of any racking if it existed.

That is a message that occurs often in older ESS versions and didn’t necessarily mean anything was wrong. If I remember right it happens when the proximity sensor does not “untrip” within a certain number of motor steps. Mine almost always did this. One of the recent ESS plugin releases changed the number of steps that have to happen before it throws this message. I haven’t seen it since.

I’ll check for an updated one. I just installed this a couple months ago, max.

I’ve had this since 2017 and have had it running well that entire time. I feel like I’m going crazy because I have figured out so much in that time and have built my own rotary axis all machined on the CNC. In mach 3 I’ve written tons of macros and could consistently cut many materials without issue. Then I had to replace parts from wear.

I’m going to set up test cuts and work through that. I doubt it’s backlash though. All new belts and pinions. For sheets, I use composite nails. Nothing is moving and tabs for my cutouts. It’s definitely the motor skipping. I did use a down cut bit and maybe enough material was pushed into the cut that during acceleration to speed, it couldn’t overcome it.

I updated to the one from the ess site instead of from what avid suggested. The avid one was 277 and then there was an update.
After downloading from the ess site, I had to change a few outputs in the ess config that avids configuration program doesn’t change when run.
I was getting a pem output pin isn’t assigned error. There were a couple other ones assigned that I carried over.

After that, I no longer receive the homing error I kept getting. At least I’ve definitely verified my racks are well set up!

I tried a test to see if backlash exists while parked again and depending where it sits on the x direction, I get anywhere between .004 and .014. specifically I get .014 when pulling out -x and .004 pushing +x. Negligible in the y.

Going to test cuts and move it all over between to see what I get next

OK. Other than the small backlash in my x axis, I believe that I have come up with an explanation of what is happening.

My downcut bit is somewhat dull on the first .125 of the bit. I checked when I ordered it and it was in 2019. I have 2 new ones coming in today and can test the same types of cuts to determine if this was one of the main causes.

On top of that, since the downcut forces the chips into the path and I was not using air to assist evacuation, this added resistance to the motion. Possibly offsetting the path by skipping. Only luck allowed for straight cuts once low enough on the bit.

I generally use compression cutters for sheet stock. Obviously I should have chekced the sharpness of the bit instead of assuming it was good.

I do know that everything is pretty good on tension now. I have changed the tension on the x several times to see what would happen while cutting my test paths.

Once I switched to an upcut bit for testing and running through a set of pockets in multiple directions and having the tool move far away from the work, move back and forth at the highest speed it would move and return to the paths to cut them over again, everything was accurate and I never lost steps.

Now I need to figure out if it is even possible to get rid of the backlash on the x axis. When parked, it can move slightly. I see the gears move and I am not sure of how to get rid of it.

The y axis only flexes, no movement whatsoever in the gear when parked and pushed/pulled. So, I can get a reading when doing this. Flex in the system though.

The proof is in the pudding…if you are able to make accurate cuts then you are probably in good shape. Depending on how much force you are using when tugging on the different axis’ you could see small amounts of movement or flex. Sounds like you have a good deal of experience with this machine. I can see where it would be frustrating to not be able to track down the issue. I don’t want to help you chase ghosts but it could probably be a driver going bad or maybe a power supply issues.
SubNoize also suggested checking your pinion drive swing arms. Do they move freely?

I was thinking about checking the drivers and the motors for any issues next. The movement I see in my x axis it’s small but noticeable. The gears and belt move along with the movement and the gear on the shaft is right. So the mirror is able to move that slight distance. The holding power at that step is not strong enough to prevent the movement. Not sure if it’s always been there or if it’s developed over time. It would explain the slight oval shape that my circles come out in. It’s mechanical backlash but everything meshes well.

The swing arm movement isn’t getting caught on the threads like described. However, they don’t move freely. I have to press pretty hard to move them. If I loosen enough to make them move easier, I definitely skip steps. The descriptions of how they should be able to move and how much to tighten isn’t clear to me. I would love a video that shows what this should look like. It’s easier to compare than to do it without any real world example other than the explanation.

Maybe it’s been covered but if your machine is 3 years old, have you ever replaced belts and pinions?

yeah. I did that recently and there was 1 pinion that was worn down. This morning I decided to try and move the x axis by hand without the motors on. I found that every rotation of the pinion gear seems to catch. I believe that this might be a part of what happens during acceleration that leads to missing steps. Tightening the bolt on the spring seems to help until it is too tight. However, I am not sure what is causing this to happen and may be the problem I was trying to solve in the first place. besides the backlash.
What would cause this? Brand new pinion and bolt for the pinion. I took a video of this to show what happens. I remove the bolt and held it by hand against the rack and the same thing happens. Almost like something is misaligned.

Well, I disconnected the control cable going to the motor just to see if manual moving the motor was inducing current into the driver. It was. So, every rotation would end up stalling the motion. Removing it stopped this behavior. I thought I was finally on to something. I will never figure this circle problem out. I see so many projects with holes so round compared to mine and it is defeating me. I just want to cut circles like everyone else. There has to be an answer to my problem. This has to be solvable.

If you push the steppers too fast you will create back emi and it will do that. Push it much slower and see if you still get the same result. Also just a fun fact. It you connect the correct pairs of wires on a stepper together it will be very hard to turn. That is how I determine pairs when I have done diy projects in the past.