Proximity sensors 'work' but don't activate

Just incase someone has an idea that saves me some headache.

Had the machine for a couple years now, using 3-5 days a week. Outside of the learning curve it’s worked flawlessly.

Today I went to setup a cut and when homing it was a clusterfuck. The left side, Y- as well as the Z++ proximity sensors are note getting signals back to the boards. Both of them light up when activated, but nothing on the sensors in Mach or the leds on the breakout boards.

Cleaned up the wires, removed and reinstalled on both ends, reset a handful of times. No changes. What am I missing?

Getting ready to head to dinner, but next I’ll swap at the box and try to narrow down to sensor vs port. What other troubleshooting is there, figured it’s pre-Mach, as I don’t get leds on the board.

1 Like

Hi, did you by any chance check or unchek the active low parameters for those.

Also if you reversed the wires this could happen , active low is basically doing that for you.

I haven’t touched the wiring in 2+ years, no settings tweaked since the last update 6-8 months ago or so.

Correction, it was Y - - and the X sensors, and the E-Stop seems to be flipped now?

I pulled the cable from the other Y and the sensor works as it should, but the when swapping the good sensor into the non-working plug/port, it has not reading, only a light? Not sure why E-Stop only works when depressed now though?

Could some sort of short have happened on the input board? I’m going to pull it tomorrow I guess since it’s Sunday, then reach out to Avid on Monday. I know I ‘can’ bypass homing, and I haven’t hit a soft limit, let along a hard top, in 18+ months, so hoping I can make due for the time being.

Anything thoughts would be great though, I’m done for tonight.

Before touching any hardware, I would make sure this isn’t just from a corrupted Mach configuration. Basically, you can check by restoring a backup Mach4 profile. Take a look at the Mach4 troubleshooting documentation. Worse case, you reinstall Mach4, which is pretty fast for a stock setup. (I don’t know what’s involved for a custom setup.)

I have no idea how the config can get corrupted, but it’s happened on my machine.

Wasn’t expecting anything on a Sunday, thanks though. I’ll give it a try today and see how it goes. My config is pretty standard outside of the laser setup.


I tried a backup, reinstalled 4809 and tried the new 5039, no luck on anything. I do have an error that shows up as well, not sure this answers anything. My concern is I get no feedback on the board when the sensors are activated, that doesn’t seem like software.

Also tested the laser today and it’s not activating. Not too worried about that as I don’t use it as often, but that was random as it worked last week.