Tool Path Help Spoil Board Surfacing Problem

Hello All, Happy Turkey Day

Trying to enjoy the day off and play in the shop a bit. I have cut some things out and I need the level the bed. I watch Mark Lindsy video and made my box and tool paths. All good there. When I go to run it I get a errorX axis commanded over softmin .
I have room for the gantry to move before it hits the stop. My machine is a 48X48 Pro. I’m guessing it just a setting in Mach4? The spoil board is 49X 48.785Y I made the box just a 1/16 wider to get all of the spoil board. Please let me know what the noob is doing wrong this time.


Almost sounds like your hitting your software stop before the physical stop.
Did you just build or move your machine? Do you have proximity sensors? They are both adjustable in x and y axis. Could it be that simple?
BTW: The x adjustments are on the back of the gantry. Avid has great instructions.

A 48x48 can cut just a bit over 49x49 IF you have your soft limits set close to the max. So you are possibly trying to travel close to the limit if you have a really small bit and/or don’t have the soft limits set right. The soft limits are in the Mach4 Control configuration, here are the settings for my 48x48.

YEs I just built the machine and this is the first time I have tried to surface my spoil board. I did set the proximities switches like Avid showed in the instructions. Thanks

Looking at your chart I’m guessing mine is set at 48 maybe. Do I change it in this screen? Or do i need to go some where else? Thanks

ya, you can change it right there and update. You might have to restart Mach4 for it to take effect.

OK, Should i match you setting at 49.29? thanks

It would probably work, but I don’t know how your sensors are adjusted, so I would recommend watching this and then you’ll know how to adjust yours and how the homing and everything works.


I did check mine and they are set at 49.5. Must be the default setting from Avid during the set up. I did set up the Prox sensors to get the max travel out of my machine. Not sure what the problem is then. What do you have you machine table set at in the general settings? Mine is at a 48". Should I change it to 49"? Thanks

No, those are AVID configuration pulldown menus, you can only select what is there (and 48 is correct).

It seems those settings are ok.

So where is your spoilboard’s reference point (0, 0), and is your X and Y set at that location? You can tell this is off if the loaded Gcode does not fit inside the yellow dashed boundary of your work evelope.


It does have a tab where you can enter a custom size in inches in that pull down next to the 48 or 60. I made my tool path box 49.125 x 49.125 to make sure it would get to the edge.

I don’t have that yellow box up on my screen. Must be a screen i don’t have turned on. Let me poke around and see if I can find it.

I’m with in the yellow lines with my tool path still got the same error. So I had it start from the next line of code and it took off and was working fine till I was almost done and it came up with that error again. So frustrating for a newbie.

So that first line, and then one later on must be just slightly outside of the soft limits.
Can you post the Gcode, or at least the first line that you skipped over?

I feel so stupid at this. How do I post the g code file here?

Took a screen shot of it. Not sure where is stopped when it has about 4 passes to finish it.

Mark does a Perimeter passed first along the edge are you doing the samething? And did it go all the way around with out stopping? If it stopped I would think your out side the yellow border lines make the area a little smaller a two inch bit should cover the corners and sides

I think you are right. I did finally get it to go but had to cheat a bit. thanks