Making grid in spoilboard problem

Hi guys I’m calling this a operators error somewhere. Machine starts up runs about 3/4 of the way in the y-axis and stops moving… What could cause this :thinking:

1 Like

I made the code twice in vcarve and the first time it stopped at 48in and second time it stopped at 40in

1 Like

Are just setting up the machine or have you had it working as expected before?

I’ve surfaced the spoilboard and ran several small projects.

Is it making any chucking or grinding noises when it stops?

1 Like

I know it sounds a little counter-intuitive (at least it did to me) but it could be that your belts are too tight.

No!! Nothing like that…

1 Like

okay… if no noises then the belts may not be a probable cause…

I checked both programs and they appear to be setup for the 6060 machine…

And the toolpaths are within the range. Sorry for all the posts i see i can edit them :grin:

No errors in the History, and the loaded toolpath is all within the yellow box on the upper right?

1 Like

If you are working with a Demo copy of Mach4 it will time out and stop working after a short time.

No its not with in the yellow it’s shifted over the back y+ position

No this is a licensed product

I see I have a error y axis commanded over softnax…

thats what I figured…but it should show that the toolpath is out of the yellow box. Is it just right on the edge?

1 Like

Yes what does that mean when its off the edge like that I haven’t been able to figure that out

1 Like


It means your toolpath is traveling beyond the soft limits of the machine.
In other words the item you are cutting is larger then what your machine can do.

If this is the case. You can work around that by doing what’s called tiling. It’s a feature built into vectrics software.

Hope this helps.

1 Like

Mr.Nick’s suggestion is a good one.
Here’s another possible quick workaround: bring the offending axis to its soft limit position and then override the soft limits in the Jogging window, then edge it further until it hits the sensor limit (It should hit the machine’s limit switch before it hits the bumper). See how much further it goes beyond the soft limit. If that’s enough for the tool path, then run it again (be sure to home first), wait til it stops, then override the soft limits and select “Run from here” in the file ops window. Mach4 will then ignore the soft limit and continue the tool path. If that works, you may or may not want to adjust your soft limits so that you can use more space on your machine - it depends how safe you feel running the machine however much closer to the machine’s limits.

Check these:

  • Machine is properly homed
  • Program is not larger than the machine can handle
  • Work offset is set correctly to keep program within machine limits
  • Program’s work offset (G54, G55, etc.) matches the one you set and intended to use

If the program is not too big for the machine, but it’s simply shifted outside the machine limits, then it’s probably a consistency issue with your work offset. Your work offset has to be set consistently between the CAM program and Mach4.

For example, if in Vectric or Fusion 360 you select one corner as the reference point, and then you use your touchplate on a different corner, then the toolpath will be shifted. Likewise it can cause problems if you choose G55 in your CAM and use your touchplate to set G54 (though I doubt this is happening as you would be lucky not to crash because of an unintended Z reference setting).