Q: my origin is different in Mach4 every time

Hi there. I don’t know if my question is related to Mach4, Fusion, or even my Avid CNC. I have a lot of software experience in CAD, but not much in Mach4 and CNCing.

  1. Every time I open my gcode in Mach4 the origin of the piece moves. There doesn’t seem to be rhyme or reason to it.

  2. My Z axis is always off. Always. So, I generally guess at it and hope it cuts through my media. Often it will cut deep into my baseboard, but at least it cut through.

Is it me or the software? Thanks for your thoughts!!

1 Like

Couple of questions:

When you open Mach for the first time are you homing to prox switches by using the built in homing routine?

If that’s the case check to see if you have any work offsets set. You can get to them in the top left of Mach under a tab called “Offsets”

See what they say and post a screenshot if you can.

Also attach your g code that’s causing you problems here and I can see if I can figure out what is going on.

My guess is that you have a bunch of offsets set, and if you’re using fusion you may have told it to go to a different offset than you turned on Mach with… I’ll know better when I see that screenshot and your code though.


The default for an origin in Fusion is the center of the stock, sometimes on top of the stock, sometimes on the bottom (it depends on the model and what stock selection mode you use).

Another issue that I regularly overlook is that the default stock option in fusion is to add a small amount of additional stock to all sides of the model to be machined. I often choose ‘no additional stock’ when I setup a job. That small amount of additional stock can stop you from cutting all the way through, or cutting too far through.

I like to use the auto Z plate for this reason, and I choose to select the center of the real life stock. This allows me to be imprecise and still get a quality result if I start with wood material that is a bit larger than my finished part. As far as the Z axis, I usually choose a little bit of offset on the bottom selection of the
heights tab. This makes sure that the tool comes through the bottom of the stock for a clean cut. I usually choose about .05" or 1mm.

Let me know if you’d like a video of how I walk students through setting up fusion for routers rather than for CNC mills.

I usually home by selecting “Home XYZ Axes” in the upper left of Mach 4. (usually, because I’ve tried so many combinations trying to figure out my problem)

Then I place my media on the baseboard and set the “auto Z touchplate” to the media corner.

I’ve attached a screenshot of my offsets. These were set by someone prior to my use, so I didnt’ change them. Also attaching my gcode.

In Fusion, I set my origin to the corner top. I’ve included a screenshot of this too.

Thanks for your help!
Gcode Box

As I suspected you have some offsets in that table… change all of those to zero. Make sure G54 is selected and go through the zeroing routine again on your workpiece (make sure you machine is homed too)

You had one of the higher ones that was set and I wonder if you accidentally switched to one of those?

Then make sure that your stock is set properly in fusion. You already homed in on the stock oversize setting, make sure that setting is off.

Then make really sure that the WCS origin one your piece in Fusion matches exactly where you zeroed on your actual workpiece.

Then setup your g code as you would normally do. In the post processor settings in fusion make sure you have g54 set as the work offset.

I’d send you a screenshot but I am not near a computer right now

I suspect what happened here is that you accidentally switched your work offset in both Mach and fusion and that’s why things weren’t lining up

That’s wonderful feedback. Thank you!
I am heading out, but will try these settings tomorrow and report back.
Best, M

1 Like

I’m getting ready to cut a new piece with the recommendations. But, where do I turn off the “stock oversize” setting in fusion? Thanks.

I would call for help.
My Mach4 is going great.

Some things are easy to type instructions for, and some things are just better explained in a video. Have a look and let me know if this helps / makes sense.

[Setup Stock for Sheet Goods _ Fusion 360]
(Setup for no additional stock + tabs.mp4 - Google Drive)


Call who? Mach 4, Avid, Fusion? Avid is the only one that actually has a number and answers that I am aware of.

I zeroed all my offsets in Mach4. Now it won’t cut at all because the Z axis wants to move up past the limit switch.

I wonder if I have an offset in Fusion I’m not aware of.

I can move the bit so it touches the media and manually select “zero Z” to get it to cut. But it’s dev not accurate.

Is it possible to accidentally wire the Z axis incorrectly (like I’ve heard you can flip the X or Y)?

I don’t think there’s a problem here, it’s just a setup issue. I think all of the pieces to an answer are here, but let me see if I can bring them all together for you.

Mach 4 (like a lot of other control programs) allows for multiple “work offsets”. They are numbered G54, G55, G56, etc. You saw those in your “offsets” tab.

Think of these like saved points on a map, you can have a lot of different saved places. You can set these manually by typing numbers in, by driving your machine to a particular location and zeroing there, or by using the touch plate.

So let’s say you’re on the G54 offset and you zero to a piece of wood you have on the table. The DRO will say XYZ 0, but if you look in the offset table you’ll see numbers for XYZ. That’s because these are offsets from the MACHINE zero. Essentially these numbers are a distance off of your home switches (Z will be negative because Z zero is at the top)

As you may have gathered you can have multiple work offsets, but to keep matters simple lets just focus on having one, the G54 one. Before you zero you need to make sure it’s selected in the offsets tab.

Now let’s move on to Fusion. When you setup a job in Fusion you have to setup your stock (as seen in the video posted above). When doing that you have to setup a WCS zero point. As noted in the video Fusion often picks the center top of the stock as default. This is likely NOT what you want.

If you used your zero plate to set your G54 offset to the top left of your material you’re going to cut, than the WCS in Fusion needs to be in the same spot.

If you left it at the center of your stock the whole cut will be shifted in two directions half the size of your stock.

Now the last thing you need to make sure of is that when you post your G Code from Fusion make sure it’s set to the work offset you’re using, in this case G54 How to define Work Coordinate Systems in Fusion 360 Manufacture | Fusion 360 | Autodesk Knowledge Network

I think what was happening to you is at some point you picked a different WCS in Mach, and perhaps even switched to machine coordinates and you got confused with the numbers there. Things likely got more confusing when you perhaps didn’t have the WCS in the Fusion stock setup perfect, and to add even MORE confusion you may have changed the WCS that Fusion used in post process. Basically there three places you could have made an accidental wrong choice.

Hope that helps, report back and let us know!

Thanks for all the detailed feedback! Much appreciated. I’ll double check my various settings today and watch the video and report back by EOD. Cheers.

1 Like

Hi fellow CNC-ers. I finished my project and am surfacing for air. With your help I was able to load the gcode file with a reliable origin.

Unfortunately it still positions the Z axis too high. Any suggestion would be greatly appreciated!

Thanks again.

Definitely reread my previous post. Double check that all of your work offsets have 0 for Z.

Another place to check for errors is in the tool table. You can get to this in the tool change tab near the bottom of the screen. All of those values should be zero as well.

If that was the case and you are still having trouble walk us through the steps you are taking and let’s see if we can figure something out.

1 Like

Great. I’ll reread and let you know. I’m not in the shop today.

Try using the fixed box size option in Fusion 360. Just enter the dimensions of the stock you plan on using add a little extra if needed in the x & y, set the z height to the actual thickness of the stock .
If you hover over any tab, you’ll get a popup explaining what that function does.