Z Axis zero changes while running a tool path

Hi Everybody,

The image is of a piece of rather large egg and dart molding. It’s about 9" wide and 8 feet long. I’m doing this with 3D rough and finish tool paths. The roughing pass is with a 0.5" bit and runs fine. Using VCarve Pro, I am doing a clearing path with a 0.5" bullnose, another with a 0.25" bullnose, and a final pass with a tapered 0.125" bullnose.

The first 3D finish pass with the 0.5" bit seems fine but when I run the next one somewhere during the toolpath the Z zero seems to change and for part of the toolpath, the bit is cutting air. When the path is done and I go to Z zero using G1 Z0, the bit does not go all the way down. If I re-home the machine and then go back to Z zero, it’s correct.

These are large files, so I broke the job into 3 pieces in case VCarve had a problem generating it or it was too much for Mach4. The problem still occurs, but less dramatically than when I ran it as one large tool path. Still, the bit ‘zeros’ about 0.1" higher than it should once the tool path has run.

I did run a test piece a few weeks ago that was just a little shorter than 1/3 of the example here and it was perfect.


  1. It’s a software issue with file size or
  2. Something is going on with the z-axis. The problem does seem very consistent, so I doubt it is some kind of slippage.

Any thoughts would be very much appreciated.


It is either a bad Z motor connection (read wires), z axis brake going bad or your Z axis speed is to high and you are losing steps in the positive direction (if you have the standard AvidCNC setup then this isn’t the problem).

Sometimes if this is a well used install is the couplers come loose in the Z axis and the spider gets smushed in there and so it doesn’t fail right away but you can see steps being lost in the Z axis positive. Usually you notice the awful noise as the motor is burning up in this case :frowning:

So the machine is a Pro 4896 and it’s a bit over 4 years old. I would say it’s had moderate use. I did just run the final pass with the tapered bit (slightly smaller file size, if that matters) and at the end the z-zero was still spot on.

I will check the couplers. My shop is not generally filled with spiders, but I’ll look.

I’m not familiar with the z-axis brake or how to check it.

And so far, no bad smells or horrible noises from the motor.

The plastic insert between the two halves of the coupler is called the “spider.”

The brake is the cylindrical thing at the bottom of the ball screw in your Z axis. It keeps the Z axis from falling when you power off the machine. When it does bad you will lose steps in the Z positive direction. To test it you can do a bunch of rapids up and eventually you will trigger the Z home switch because you are losing steps.

So next time this happens, take the Z axis to the very top. If it triggers the homing switch they you are in fact losing steps in the positive direction.

Thanks! I didn’t think you meant an 8 legged insect, but I wasn’t sure. And thanks for the explanation of the brake. I’m sure this is generally true, but my z axis came fully assembled except for the motor and coupling and all I’ve ever needed to do with it (so far anyway) is grease it.

Thanks for replying so quickly.


I check the couplers every 60 days. I check the brake every 6 months.

To check the coupler I assume you take the motor off and visually inspect it. How do you check the brake?

The electrical connections seem fine. I checked the coupler. It look just fine and the spider looked pretty much new. No metal filings, plastic shavings, or dust/dirt apparent. I’ll do more tomorrow.

Move the Z axis as low as it can go and unscrew the dust cover at the top. With the motors still engaged but the estop active take your fingers and try to twist the coupler around as well as up and down. If they are loose you will see them move. You can take the top motor off to if you want further proof. I do that myself BUT be careful as the axis will want to drop when you do that. Make sure the little plastic spider doesn’t actually grow legs and walk off during this procedure.

The brake is harder to test. But, it will click and move around while you move the Z axis up and down. This time unscrew the dust cover at the bottom with the Z axis at the top of its travel. You will also need to rapid up and down at the highest speed a number of times (which makes a great exercise for lubing the axis) and then go to home and if you trip the homing sensor then you are losing steps.

I do these while I am lubricating axis so you should make these part of that checklist.

Ah. Thanks for the details. I didn’t take the dust cover off just now, but I did take the motor off. The axis did drop a bit, but it wasn’t a problem. And the spider stayed put!

Could be one of the mechanical issues mentioned. Could also be the step pin on the Z axis. The AVID setup has some kind of signal marginality (probably between the ESS and motor driver) that can show up in very long carvings on some machines. It shows up as a gradual drift up over time due to lost steps in the down direction. I know at least 4 or 5 of us that have had this problem and the recomendation from AVID was to change the active level to low on the Z step. This completely fixed mine and the others I know of.

Jim - thank you very much. I did run various versions of the tool path today. First I ran it as one path, then I split into two, and then into thirds. While I didn’t measure the z variance carefully each time, my impression is that the variance was more with the longer path, which fits what you’re saying. Also it fits with the fact that this is the longest tool path I’ve ever run, I think. I’ll try this and report back. Thanks again!

Hmmm… I had a similar problem on my linuxcnc setup - noise on the step line caused the motors to drift sometimes (usually during startup, before the line was actively driven). The stepper drivers on the old machine had a quadrature mode you could use instead of step+direction; I run my servo drives that way so that noise on one pin tends to cancel out instead of accumulate.

I don’t know if mach supports this mode, though.

1 Like

Now you are just bragging :expressionless:

Perhaps :wink:

But if commercial stepper drivers support quadrature, it follows that there must be commercial software that supports it. One hopes :slight_smile:

Later: yeah, a bit of digging, and mach does support quadrature, at least through something called “Max CL Mode”

Sounds promising.

I am done with Mach4 and the ESS :face_with_peeking_eye:

I changed the active level to low on the Z Step in the ESS Configuration. So far I’ve run two tool paths that exhibited the problem and both of them have been perfect. Thanks Jim for the suggestion and thanks everybody for jumping in quickly to help.


I’m glad it helped.

@Eric maybe AVID should consider making this change in the default configuration?