Zeroing bit change (vcarve and mach 4)

Im new to CNC. in my project i used vcarve to set up using a 1/4 and 1/8 end mill bits. I loaded the project with cutting all 1/4 bits 1st. I set a tool change position. when it came time to change the the bit to the 1/8 i couldn’t get it to zero the z. Once the bit hit the block it stopped and nothing happed. i tryed to see if i put the 1/4 back in and zeroing z and nothing worked. to finish my project i deleted g code and uploaded only the 1/8 code. Everything worked and is cuting that bit now. what am i missing for bit changes?

thank you


Export each tool size as an individual file.

put your 1/4 in and use your corner finder to set your z zero and find your starting point. Make set the end mill size in the probing menu for your endmill.

Run the tool path.

When the machine is done it will go back to it’s starting point and turn off.

Put in your 1/8 endmill and then run your z zero again. Do not run the edge finding portion though because you already have that set from the previous setup.

Run the 2nd tool path and it should work good.

So to zero in on your issue. Is your endmill coated in something that may prevent electrical conductivity between it and the touch plate?

In mach 4. The probe program will travel a max of 2 inches. So if your endmill was just outside the allowable travel distance it may have reached its stop point before touching the plate.

Check your dust collection hose. I have had mine trip the limit switch after probing and it’ll stop and go into a emergency stop state because it thinks the proximity switch has been hit.

Hope this helps.

Let me see if I’ve got the facts straight; when you finished with the 1/4 bit you used the zeroing tool with the 1/8 bit, picked the center tool, z only, had the magnet on the bit, not the nut, it touched down and just stopped, not retreating back up? Then, I assume you manually retracted the bit in z and replace it with the 1/4 to again do a z only touch down and the same result happened. But then when you started over with a 1/8 only toolpath and again, I assume, you did a whole corner touch off and it worked just fine that time with the 1/8 bit.
If you did all this, doesn’t sound like you did anything wrong. Perhaps you need to polish your touch plate, maybe your bit had something on it. But if that happened I’m not sure why it didn’t drive right thru the touch plate. Perhaps somebody else has a thought.

Looks like MrNick had a couple of ideas while i was typing on my phone.

yes thats exactly what happen. i did the 1/4 bit just to see if mt 1/8 bit was the problem. which it wasnt. So the zeroing tool only seems to work in the beginning but not at a tool change. Any ideas anyone.

so when i have tool changes alway export them as mulitple files?

I always have mine as separate files, put them in a properly named folder and just name them so I know what it is and what bit and what order. For example:
“1 Jessica Heart Inner Pocket .25EM”
“2 Jessica Heart Vcarve Letters .25V”
It seems to work for me and I haven’t seen your issue yet. Maybe off topic but I have noticed the few times I have seen the machine get stuck and not move on like it is supposed to, I was using my cell phone near the controls.
I don’t know if it actually has an effect but wondering if cell phone interference could be and issue for our machines.

Yes i do the same thing. I have always skipped tool changes because I found it took longer to setup. Have the machine job somewhere so I can change the endmill then try and get it to continue. So I set my machine to ignore all tool changes in mach 4.

My naming is a bit more ugly. Profile .25 run 1st.
Profile .125 run 2nd

I have never seen cell interference, not saying it’s not a possibility. But have many times had my dust hose trigger a proximity sensor. The machine just stops.

Do you get a message in mach 4 stating why it stopped or what state the machine is is?

Maybe enable logging to get a snapshot of what it happening. Then we can have a look at what is being sent as a reason.


The few times it stopped it was almost like it was looking for the next line. My dust collection hose is run sloppy as hell. Never thought it could be triggering the prox sensor, but now that you say it…would make more sense than random cell phone interference. I will get logging set up. Thanks for the tip.

So this vacuum hose setting off the proximity sensor on the z axis. I presume you have a flexible hose with internal wire support and it comes off the top of the spindle going to the right side of the machine. Therefore it could fairly easily roll up against the switch and the internal metal support wire sets it off. Hmm, interesting. My vacuum system sits off to the left side of my machine, therefore my hose goes left, so it never gets close to the proximity switch.