Help resolving a Z-Axis issue

Folks,
I wonder if anyone can give me any hints as to what may be going on. I’m running a program, everything is going fine! Then the spindle retracts to move…and suddenly…it drives all the way to the table.

It is not the program. I stopped and reran the program again and everything worked fine. The machine has done this a couple of times now with different bits loaded.

Thanks
WTB

I’ve had this happen and am very curious what might have caused it. My best guess at the time was that my laptop power cord came unplugged and that during the transition from wired power to battery it missed some steps during a retract. It seems pretty unlikely, but that’s the best I came up with.

Make sure your computer running mach4 isn’t doing any other processing while running a g-code. Mach4 wants all the resources and acts badly when it can’t get them all. No browser, no email, no anything else running at the same time. Maybe if your computer is super high end but I run a laptop with an intel celeron and only 8GB Ram and Mach4 gets real unhappy if anything runs at the same time.

1 Like

I heard back for the Avid team. They think my machine is too slow to handle Mach4. It is an older machine but it is 100% dedicated to the router.

Weird that it works most of the time.

Thanks for everyone’s feedback and assistance.

3 Likes

I had this very problem. It is intermittent too. Drove me bonkers.

My problem was with a faulty brake on the ball screw.

On mine it would sometimes stall on the rapid Z up and then come back down and drive right into the stock or tool carousel or frigging the table itself.

Does the Z axis click when you rapid up? If so it is probably exactly the issue.

The way I got the factory to take a look was I started video recording it. I finally just wrote some g-code to rapid up and down until it stalled and dover deeper on camera.

I think this one issue cost me about $12,000 minimum in repairs over 3 years.

Sub,
What was the fix for the problem? A replacement sensor or what?

I have the 48x48 Pro. I’m not sure the Z is tied to a screw…but I could still see a potential sensor issue as the problem.

Thanks,
WTB

No, replacement of the Z axis brake. Ball screws will allow the Z axis to fall when powered off so the factory installed a brake to stop that behavior.

When that brake goes bad, the factory will have to install it for you. Its suppose to be a permanent part of the ball screw installation.

Trust me, your Z access has a big ol ball screw tied to it. It makes the Z axis move up and down.

So, no, your sensor is fine. Test the brake.

You can also try this;

  1. Move the Z axis to the maximum height
  2. Unscrew the bracket that holds the cover fabric and pull it up so you can see inside
  3. The brake is the small barrel shaped thing that the ball screw runs through at the very bottom
  4. Take your fingers and see if you can wiggle it

If it moves, you have problems. It should be installed with no play. It shouldn’t make any clicking or crunchy sounds when you rapid up and down.

My computer meets the software requirements just fine, so I don’t think that’s the problem. I think my Z-axis does click when I rapid up. I’ll take a look tomorrow.

@subnoize, can you clarify why this cost you $12k in repairs? And in the end, you shipped your Z-axis assembly back to Avid to get it fixed?

Crashes into the table, ripping the core out of an ATC spindle, wrecking a tool carousel (twice!), broken end mills, broke tool holders, wrecked ER32 collets, rejected product over time to name a few things. All for a $5 brake :rofl:

The rejected product was the most humiliating. Like processing Royal Marine A-A plywood for aircraft. I was ripping through 1/4" stock and about 1/10th of the parts per sheet were messed up because the tabs were cut incorrectly (long before I built my flow through fixturing). The tabs would slowly disappear as the Z was losing steps. Eventually the pieces would come loose and the end mill would take chucks out of them. At $150 to $200 a sheet it doesn’t take long before you have a huge loss.

Oh, and I forgot! My newest pet peeve! Messed up spoilboards!

You should only have the lightest, if any marks on your spoilboards.

When you are gouging spoilboards and replacing them at a rate of 1 a month, that is really, really expensive not just in finding and buying a 61 inch x 121 inch piece of 3/4 inch MDF (they are rare and not many companies carry it) but in processing them with mounting holes and leveling them!

Ugh! I was a metal guy getting into wood. I should have realize what was going on but I was in denial :roll_eyes:

wbest,
I had a similar problem a few weeks ago. What I found was a loose connection on my Z axis at the stepper driver. I found a few no so tight connections, but the one on the z axis fell out as soon as I touched it. After I tightened all the connections in the control box, I have not had the problem again.

Sub,
Looking for some feedback on your suggestions. The Picture has a big orange arrow pointed to what I’m guessing you call the Z-Stop? That thing wiggles back and forth about 1/16" of an inch. The video is the machine going up and down with a G0 command.

I’ve checked the wiring. And other than a bend cable right where it comes off the motor into the cable guard it looks solid and tight.

And the Video

It’s got a clicking…but not what I’d call a grinding.

Thoughts?

Thanks,
WTB

1 Like

That thing with the arrow to it is a brake. Just like in your car. It keeps the Z axis from falling when you turn off the power to that motor.

My understanding is that should not be moving or making that kind of sound.

The factory had me try gluing it down using locktite but that never worked in my case. You could be a squirt and done, dunno! :thinking:

I would write a nice email to support@avidcnc.com and say you suspect you might have a bad brake on your Z axis and that it is causing you to lose steps only in the Z negative direction intermittently. (That is because the weight and orientation btw, it would do it both ways if they were equally loaded)

Share with them your video and photos.

You caught yours early so that is a good thing. It’s easy to remedy. It’s not that expensive either.

At least you have more info! It might be something else entirely though so don’t get sad if I am wrong.

BUT! If I was correct, please mark my reply above as the solution so that others can find it.

Best of luck!

Figured it out. Tucked way in the back…hidden by the nefarious cable snake tray…

A persnickety problem was hiding from plain obvious site. Going to get a friend to re-solder that for me tomorrow and I think my problem will be resolved.

Looks back I think the wire got pinched in the corner of the cable snake. When I re-hook, I’m going to remove it from that tray entirely.

Thanks,
WTB

Looks like the Rack & Pinion gear munched on it :rofl:

I had that happen to the torch cable.

Good to hear you found the problem and it was simple to resolve. Much better outcome that the other.