Problem with upgrade of ESS from 275.? to 278.1

I think it was 275.1, but not positive, shouldn’t really matter here. Everything seems to be working, the spindle does turn on, but I got this error in Mach4’s history: The spindle PWM pin is not enabled or assigned. The spindle PWM will not work!
I ran the SCU again, I ran their install video and tried to follow the instructions from Warp9 to the “T” on installing, restarting, checking the ESS settings under configuration, restarting again, rechecking, restarting, etc. Everything seemed okay, but I don’t know just what PWM is or where to find it to turn it on or “assign” it. Something ain’t right!
Any ideas?

Steve

I believe the current ESS version is 277.1

Are you downloading Mach from our website?

https://www.avidcnc.com/support/instructions/software/downloads/mach4/

Our current released version can differ from versions you find elsewhere. Ours has been customized by us and for your machine specifically. Unless you have something custom going on in terms of controller hardware this is the version you should be using.

As Jamie from myth busters would say, “there’s the problem!”
No, I did not, but I should have known better! I went to Warp9 and got it. I’ll fix that tonight, Uninstall and go to Avid and reinstall it. Makes perfect sense, i know you guys have your own version. Another noobie screw up.
As my son would say, “welcome to the world of CNC.”
I’ll get there someday.
Thanks Eric!
Steve

Glad to be of help!

Let us know if you run into any issues.

Good to have you and other people here that know what they are doing and willing to share. I hope to be one of those one day.
I knew better than going to Warp9’s website for programming, but i forgot i knew that, i think that’s called a brain fart!
Steve

I went to the Avid software page and upgraded to the latest version, 2.3.8 and I ended up with that and ESS version 278.1. When checking the Avid CNC Mach4 configuration , the help tab shows the current version is 278.1 and the required version is 277.1. It also shows the current TMC3in1 plugin is “001” and required version is “022.”
The screen certainly now looks like it did before and it appears everything works, but I still get the PWM spindle is not engaged or assigned.
Oops.

Steve

Ah so I’m on a slightly older version… looks like I need to update :).

Check this troubleshooting doc Mach4 - Troubleshooting

If nothing in there works I’d contact support

From Warp9’s getting started guide:

“ESS build 278 (and higher) changed the name of the output signals for Spindle PWM and Laser PWM on the output signals tabs. This was done to reflect that the Spindle is now also Analog out 0 for M67 and that the Laser is now Analog Out 1 for M67. As you switch between 277 or lower and 278 or higher, you will lose your Laser PWM and Spindle PWM pin assignments on the output signals tab.

See:

1 Like

Now Eric, don’t get too excited about that upgrade, I didn’t see anything mentioning the ESS with the Avid Mach4 upgrade, so perhaps it just left the 278.1 version that was already there. I don’t know for sure. I suppose I could go back and reinstall 277.1 as an option too.
ThinkboxTech: thanks for your response, that helps clarifies things a bit. I assume that PWM stands for (Pulse Width Modulation), and evidently I need to possibly follow your link on setting up the SmothStepper and Mach4 on Warp9’s website. I don’t have a laser, but I understand that your saying since they added that, it changed the PWM for the spindle too and that’s probably why mine is now unassigned.

Steve

All you need to do is go to the output signals tab on the ESS configuration and reassign the correct pin to the “Spindle PWM Or AOut 0” output. See:

@Eyedoc1701

Allow me to clarify a bit what I said before and add a little more detail:

Mach 4 is made by one software vendor. The ESS (Ethernet smooth stepper hardware board) is made by another vendor. The ESS folks (Warp 9) also make a plugin for the ESS to talk to Mach.

We (Avid CNC) take a particular version of Mach, the ESS, and it’s supporting software (the ESS plugin) and customize it with our own software and installer.

We don’t always have the most up to date versions of Mach, or the ESS ands that’s because of the customizing and testing we do to make sure that all of this hardware and software plays well together.

Whatever version is available to download from our site is the latest version you should be running Mach4 - CNC Software

So even though you might see some new feature or a bug fix on Warp 9s site, or Mach, that may not be integrated into Avids version.

Go back and have a look at our troubleshooting steps: Mach4 - Troubleshooting

In particular this one: Mach4 - Troubleshooting

All of these docs have been written by our support folks to help deal with common issues on common setups, which is I think what you have.

If those steps don’t work, contact support and one of those folks will happily walk through it for you.

Hope this helps!

(and I hope you don’t mind me laying this all out again, just want to make sure you have the right info, and anyone else that may find themselves on this thread)

2 Likes

When you get more familiar and want to change ESS versions a good way is to make a copy of the mach4hobby dir and rename it (I just add the date) then you can try different versions and screen sets and if you get stuck just copy the last working one back.

I really appreciate everybody’s sound advice on this matter! I believe I solved my problem just a bit ago. I ended up uninstalling my Mach4 and Avid SCU updater from my hard drive, then went to Avid website and downloaded the Avid version of Mach4 again and reinstalled that. According to their notes, it would load the SCU updater and Vetric files for my Avid machine. I reconfigured the machine file for my machine and restarted my computer. When I started Mach4 it still had ESS version 278.1. Not sure why, but it did and the same error of the PWM spindle issue showed up in the history line and saying it wasn’t assigned or installed. At that point I decided I was going to have to manually replace the 278.1 with 277.1, just like I did before. So I went to Warp9’s website and found 277.1, downloaded that again and replace the two files in the Mach4/hobby folder with the two for 277.1, and voila; when I reopened Mach4 it was again ESS version 277.1 and no PWM error!! So I think I’ve fixed my problem. Hopefully; time will tell for sure when I try to load a Gcode and run a file.
I guess that’ll teach me to mind my own business and be happy with the programming Avid recommends!
Thanks for all the help and advice guys! This is a great bunch!
So much to learn to figure all this stuff out. Good practice to keep an old brain sharp!
Hope I haven’t been too much of a pest getting myself in trouble and asking for help here. I promise to keep getting better and try and help somebody else out in the future. Hopefully I may even have some project to show here someday too!
Steve

You shouldn’t download an ESS plugin from Warp 9. We package all of that stuff up and compile and test it all. Whatever we have on our website is the version of Mach, ESS and our we have battle tested to work well. I only mentioned I was on 277 because that’s what I have and clearly I needed to update mine.

To ensure that you are running the correct setup I’d recommend you clear out what you have and only run the control software that we provide for a download.

Whatever we provide in the downloadable installer on our website should be considered the most reliable and up to date. if you want to use some other setup you’re welcome to but please do it at your own peril :slight_smile:

1 Like

Well Eric I did download straight from
Avid and it contained or at least didn’t replace the 278.1 version and Mach4 still bitched about the PWM problem. I figured since I caused the problem by switching that I’d switch it back the same way and it seemed to shut up the bitching at least. Where else can I get ESS version 277 than from Warp9? I don’t see it on Avid’s website, only the Mach4 download and ESS goes unmentioned.
Steve

Avid doesn’t seem to provide the ESS plugin stand-alone, it’s all bundled presumably so everyone has the same combo to support. You should probably follow the documentation to remove ALL of Mach4 and replace ALL of Mach4 if you want to end up with the supported package. Anything else may cause headaches.

https://www.avidcnc.com/support/instructions/software/mach4UsersGuide/#reset-mach4-installation

*not saying people can’t pursue the best combo for themselves personally, just sounds like in this particular case you’re prepared to go back to the supported combo

1 Like

Hey David,
You are correct sir, I am in this case, prepared to go back to the supported combo!
I was all over Avid, even in the users guide, obviously didn’t go that far down the list to see this. Looks like I did everything except delete the Mach4 folder and that is where the version files are located. Evidently uninstalling/reinstalling Mach4/hobby doesn’t cut it.
Thanks for this new insight! This evening, when I get a chance, I’ll do it again and see if I can get a “pure” Avid software going again. At this point in the game, I way to much of an amateur to start making up my own game. Thank you David, Eric and everyone else for all the advice trying to get this guy back on the right track, much appreciated.
Steve

You’re very welcome!

Sage advice from @davidcnc. I’d make sure you just completely delete Mach (the folder and all) and just start with our download.

Everything you need to Mach is in our installer. It works for everyone right out of the box. If you get stuck on something that troubleshooting guide will help because it’s written for that Mach download that we make. And if you’re super duper stuck you can contact our support. If you do have to contact support, they’re going to have a WAY easier time fixing stuff if you have a stock setup.

Once you get really comfortable with our software and as david says have a VERY specific need to “go off the beaten path” with our control software you have that option, but I wouldn’t even think about it until you graduate from amateur status. Lucky for you is that we’ll all help you graduate as fast as you want! :slight_smile:

1 Like

Well guys, this saga may be coming to an end (Now don’t everybody exclaim, “thank God” at once)! I cleared my computer of everything related to Avid, Mach4 etc. and started all over at Avid’s web site and downloaded the Avid CNC Mach4 installer, ran the SCU and configured my machine and it appears I’m back to square one! Yea!! :laughing: A clean install of Avid’s configuration for my machine.
Hopefully I’ll quit bugging everybody about this and move on now.
Thanks everybody that contributed, I’ve learned quite a few lessons in this one. Now, on to flattening my spoilboard. :face_with_raised_eyebrow:
Steve

1 Like