Proper way to stop and restart

I’m having a problem. when I run G code and half way through I figure out I need to make a change to the toolpath, what is the proper way to stop and go back to XY zero? If I hit feed hold then stop it requires me to re-home the machine. I dont want to do that cause I lose my preset XY.

Can someone help me out here? If i have not elaborated enough let me know. I dont want to have to re-home ever time i stop half way through running some Gcode

1 Like

I’m having the same issues

Hope someone is able to tell us how to avoid having to re-home every time.

I’m probably going to call avid on monday

What i do is slow the feed rate down by using the override key So the machine is basically stagnant or crawling. Click the free hold button (yellow button) Wich is basically pause. Then click the stop button. You should now be able to go to your starting point without having to rehome.

The reason you have to rehome is because when you tell the machine to stop by using the stop button or free hold the machine loses its place in space because there is a bit of momentum that causes the machine to still move. By slowing the feed rate down the chances of the machine carrying forward any when you click stop is reduced.

Hope this helps

1 Like

The re-home on e-stop is a configuration. It’s on the General tab in the Mach4 config.


Be very careful. If the gantry is moving at high speed and you hit stop it can lose steps because of the weight of the gantry and the fact you are on R&P and not ball screws. I have seen mine slip a tooth or two and I broke a dust manifold trying to dock the brush after that.

UPDATE: See if this is what you are looking for…

So what you saying is uncheck that box and whenever I do a stop in the middle of the gcode I need to make sure the gantry is moving incredibly slow so I won’t lose steps?

Well, just slow “enough.” Like NOT in the middle of a rapid.

Are you using e-stop or cycle stop? I am not sure if this works for cycle stop. Do check that before you are in the middle of a real project.

As far as work offsets, if your homing is accurate then you shouldn’t have to set your work offsets again.

If you are changing out a tool, do start getting into the habit of touching off to your spoilboard and making sure your zero is the surface of the spoilboard in CAD/CAM.

This allows you to find your work offsets Z accurately and to save your spoilboard in the process.

I’m using the stop button on the screen not the physical button.

I didn’t realize when you have to rehome it still keeps the coordinates I set with my touch probe. I’ll test this out today.

I hope I’m following what your saying. Like I said I’m going to test all this out on my machine today.

Thanks for the help I sure appreciate it!

In long production runs with jigs, I will set the work offsets once and just re-home every morning when I turn the machine on. I actually do re-home about ever 4 or 5 cycles though. The rack and pinion does have a stated error rate that will progressively build over time.

But if your home is reliable, everything should be right where you left it.

Glad to help out.

PS. Your homing on these machines is also temperature dependent. Keep your shop at a stable temp. A cold machine will contract ever so slightly and then as you get it warm by moving it around it will grow and not be as precise.

On my machine when it is cold and the last time the gantry and Z/U axis moved was to the soft limits, the limit switches will all be tripped and I will have to back them off manually.

Hitting stop while motors are moving will usually cause you to lose steps. However, hitting feedhold first should fix that. Are you sure you are losing position when you do a freehold then stop?

When I use Feed Hold, wait for it to pause, then hit Stop on-screen - it does not lose Home.

Are you running Mach3 or Mach4? If Mach4, I would make sure you’re running the latest release (late 2021 I think).

1 Like

I use the reset button for this. You don’t lose X/Y/Z. I wish I didn’t have to use it at all!

Yes, MACH4 latest with a PRO4896 Machine i purchased about 6 months ago

i really dont know, I have not had a chance to test since posting this message. I normally hit feed hold then stop. then I will close the gcode and load the new gcode. once i hit start it tells me i need to rehome my machine.

I think it might be time to reinstall Mach4. I know there’s a step-by-step process on the Avid site somewhere. The only time it will de-reference home by default is if you Stop it while it’s moving (screen button or E-stop) or Disable. (or lose power/communications, etc. but I don’t think that’s your problem).

Feed Hold = Finish current line and pause
Stop = Discontinue command sequence immediately and wait for new instructions

The method you’ve described works fine for the others who have posted in this thread so far. Something isn’t working as intended.