Runaway jog problem

I have an intermittent problem that I’m interested to see if anyone else has seen.

It has been happening for a year or two, and its so intermittent that I’m only starting to piece it together based on all the events over time. I can’t really reproduce it enough to isolate the cause.

So when I start up Mach4, if enable the machine and then immediately do a long jog with the keyboard (like for a foot or two that I do to get it close to 0,0 so homing won’t take so long), one out of 10 times (very approximate) the first axis that is struck with the keyboard will stick and when I release the keyboard key it will keep jogging until either it slams into the end (it hasn’t been homed, so no soft limits yet), or I tap the jog key one more time and it will stop immediately. Often i will hold down both the X and Y jog at the same time to get to 0,0, and the first one is the one that hangs, and the second axis will stop when I release both keys.

-It doesn’t do it if the first jog is a short tap, its only when I hold down the jog key for a while.
-Can happen on X, Y, or Z.
-It will never happen after the first successful move of any axis for the duration of Mach4 running on the machine.
-If I power on and immediately do a Home All, it can happen to the Z axis as well during homing. At first I thought I had a bad sensor, but then I realized it was the same issue. Z is my first axis to move, and it is the same frequency, and only happens if it is the very first move after starting Mach4.

Its not that big of a deal when jogging because I’m aware of it now and just double tap the keyboard. However, when it happens during homing it just slams into the top of my Z axis and i have to hit emo or disable (the motors just keep trying to drive, ignoring the prox sensor).

Its like once it starts moving, it can’t respond to anything, like the keyboard input lift, or the proximity sensors.

Was hoping others may have some info on this to help figure it out, or maybe already solved it.

Thanks.

I had a similar thing happen with mach 3. I had mine set to incremental mode and would hold shift for jog, but sometimes it wouldn’t stop. Turns out its a glitch, I found a forum thread on it. One guy used a brain to trigger the e-stop if that happened, did that on mine and eliminated the issue of even attempting it.

Hey Jim! What keyboard are you using? I wonder if that has any type of consideration for it. I know some bluetooth keyboards have more latency than wired ones. I remember you reproduced that one Mach 4 bug of it resetting the home position that I could make happen when smashing two keys at the same time.

I don’t have any more ideas on what could cause it, but what about adding a button to your screen that goes close but slightly off of home position. You can hit that button before powering down, and then you don’t have to jog without the machine homed.

I have been doing that for some time now. Saves a lot of time and keeps the time the machine is unhomed to a minimum, always a good thing when using Mach4.

Ya, I’ve thought of a couple of workarounds. For now, the easiest is to just get in the habit of taping a couple short jogs in X and Y when I power on or restart M4. Then if it runs, I can just tap again.

I have scanned all the NFS and other forums and haven’t run across anyone else complaining about it so maybe its just me :slight_smile:
Jim

The problem is that it affects my jogging too. So if I don’t catch it in jogging, it will ignore the proximity sensor and slam into the hardstop, and the motor just keeps trying to drive until I Estop it. It seems more like an ESS or M4 bug, not related to keyboards (all of mine have done it) plus the homing routine does it too.

It definitely sounds like it. I have seen that happen once on my Z-axis. I’ll keep my eyes open for anything that might be related to this, in case it might help you figure it out.

I have had the similar issue, along with others as listed in my post on missing steps.
After doing a bunch of stuff with nothing really fixing the issue I stumbled on something, can’t remember where though, that it could be the ethernet cable.
So, I replaced my cable with a shielded cat6A cable, made sure the routing was as clear from my dust extraction piping as possible to avoid any potential static and since then 3 - 4 weeks now I haven’t had a single issue and I am doing production work everyday, the confidence I had lost in the machine has pretty well returned now … just hope I haven’t jinxed myself :slight_smile:
Shielded cables are cheap and I would recommend trying it out to see if it resolves your issue.
Cheers
Gus

I don’t think that is the issue. I already have a sheilded cable and its not routed by the DC hose (plus I have a static dissipative DC hose). My problem only happen one or two times out of ten on the very first move after a mach4 startup. It never happens after that.

Thanks Jim.
It may well be that I simply had a bad ethernet cable and the shielding etc were not required.
All I know is that any of the issues I was having prior to changing the cable have not reappeared (yet) and I am running the machine everyday in a production setting so was seeing the issues on a regular basis.
It is just a suggestion of something to check for those who are otherwise pulling their hair out.
Cheers
Gus

Hey Jim have you totally ruled out the keyboard? Was wondering if you use m4 screen buttons full time will it do the same thing have similar issues?

Yes, because both of my keyboards do it when it happens in a manual jog, and it is only on the very first move upon Mach4 startup, and it will happen on the homeing process on Z if it hasn’t been jogged before.

So you have used a touchscreen or a mouse and it still happens? If it did i would say it’s a m4

No, I don’t use the mouse to jog (inconvenient), and I don’t have a touchscreen. But the homing process is a mouse click, and invoves jogging via M4 API’s.

I have experienced this same issue. Seems like another bug, unfortunately.