Pulling my hair out!

Greetings everyone! I am literally pulling my hair out here. I’ve been having ‘gremlins’ pop up on and off related to soft limits and locking my machine. I just tried boring 6, 1.5” bores. After homeing the machine, loading the g-code, and hitting cycle start, the machine gets to the first command line for X,Y axis and goes into a pause one of the axis makes a ‘thunks’ and provides the error in history “x axis over soft limit max” which I can’t reconcile. Z is in the machine home 0.00” position. Incidentally, my jog buttons on my keyboard won’t work all of a sudden, but the machine responds to HOME ALL and MDI commands. HELP!!!

Thats strange, because a soft limit violation shouldn’t cause a clunk, or the jogging to stop. Usually those two things mean you’ve tripped a sensor, not the soft limit. However, your message does indication a soft limit violation. I suppose it might be possible to get them at the same time if you are particularly lucky. The soft violation could be anywhere from where it stoped to around 20 lines down the Gcode file since it is looking at the whole look ahead buffer for soft limit violations, and 20 lines is the default for the buffer.

But if Z is in the home position, its probalby the one that tripped the sensor. Is the light on the Z sensor tripped, and is it lit up in the diagnostics tab?

1 Like

Big thanks for jumping I here, Jim! To answer your questions, none do the sensors lights in the Diagnostics tab and none of the activation switches on the actual sensors are lit. I am convinced this is related to a growing problem with my homing procedure. When homing, the machine moves to x,y,x =0.000…and then periodically jump to some arbitrary small value with a clunking noise. The photo attached is from my most recent homing attempt.

1 Like

Several months back I had the same clunking issue (but very infrequently) with one of the Mach4/ESS releases I was using. The clunk was on the backoff when it moves back from the first slow backoff. Haven’t had the issue for a few months now. But I have been switching ESS and Mach4 releases so much I couldn’t tell you which one it was :frowning:
However, it didn’t misbehave after that, just had the clunk.


It sounds like a very similar issue. When I home it clearly registers 0.000" on all axis, for a split second, then your hear that noise and the Axis position jumps .0008 - .0015". Sometimes It’s Z only, sometimes x&y, sometimes all of them. Would that be an ESS issue?

Have you contacted support about this yet?

I haven’t had a chance yet, Eric. I will try to get an email to them this week.

Part of the problem was resolved. I have no idea how it happened, unless there is a hotkey assigned to jog rate percentage that I don’t know about, but jog rate was inadvertently set to 0%. At the time, I was pulling my hair out with all the oddball problems that I was overlooking the obvious. After I slept on it and approached the machine with fresh eyes, I noticed the jog setting. So that was all resolved. Still not sure how it happened, but my laptop was on the bed of the machine at the time I was working so sometime could have hit the keyboard. Once I was able to jog, I shut the machine and the computer off, rebooted both, re-homed and then set x/y/z work 0. Before I did that, I checked the offset register and noticed my G54 was correct, but my Z=0 was WAY off. I still am at a loss for how that happened as well as I used my touch plate to set g54 X/Y/Z literally just before my jog was reset to 0%. So after I used the touch plate, I loaded the program, hit cycle start and everything started locking up.

I feel really stupid, and honestly I am sharing these details in the event someone else has something similar happen, they might remember reading these comments. BUT, I still have the HOMING issue.

Does anyone know whether that “!!!WARNING: A motor seems to be stuck backing off of a home switch! …” status message is normal, or does it require attention and adjustment? I also get that message, but I haven’t noticed other symptoms.

I have heard the hard “clunk” when jogging and the machine stopping. I was able to consistently reproduce it by doing quick jogging movements with my keyboard; particularly when I switched from one direction to another and mashed the keys together at the same time. This happened more with a bluetooth keyboard, possibly due to the latency with bluetooth compared to a wired keyboard.

So, if you are quickly switching directions when jogging, be more careful about it. It is definitely a Mach 4 bug.

I’d guess that the jog rate of 0 caused your issue because the machine uses that rate for doing some backoff movements, and it wasn’t able to backoff because it was at a 0 speed.

Your G54 Z being off might be because it was assigned when you weren’t homed right.

Have you tried starting fresh, which I think you said you did in your last post? IE: rehome, set x/y/z to 0. Turn off the machine, re-home, and check the work x/y/z. Is it still way off?

If those steps fail…then there is something wrong with homing itself.

The clunk noise was independent of the jog rate being set to zero inadvertently. It only happens immediately after if backs off the limit switches during homing, and then the DRO immediate jump on some or all axis to a negative value, usually less than -.0008, or -.0015”. It sounds exactly like the motors have just been engergized.

That error “WARNING!!!…”, I believe is communicating the same issue. Of note, after home, the machine can be jogged without hitting limit override and the soft limits work. I would have expected it to treat soft limits as if it wasn’t homed (deactivate) based on that motor warning.??? You know like when you don’t home and travel to your sensor and it trips? You have to activate the “ignore limits” and then jog it manually if the switch.

Incidentally, when the issue with HOMING occurs, if I reboot the program, it often resolved itself on the first few homing procedures.

That error is typically caused by a belt being too loose. tighten the belt a bit on that axis.

Interesting. Would you suppose that if some of my belts were a touch too loose, that I would not only get that warning periodically, but my final HOME position would stay in the negative (-0.0XX") on the readout like I am experiencing? I would think a loose belt would possibly lead to excessive backlash. Mine was measured and corrected for .0005" on X and Y, and nothing on Z, which I was very pleased with.

This is an ESS plugin warning . It means a timeout has occurred where the backoff didn’t trip the sensor soon enough. It can mean there is a problem, or if you have your backoff speed slow enough this will occur due to that. The timeout value was recently increased in one of the latest plugin releases because it was tripping too easily. My machine was homing just fine but usually there were one or two of these in the logs.

1 Like

So, Jim. In my case, could the backoff be set too slow, so that by the time the backoff timed-out, the values are still in the negative? Is the homing speed tied to the back-off speed?

I doubt it. That is just a warning, and I’ve never seen it actually stop the homing, its just letting you know that it took a while. The Warp9 guys put it in there in case people had their motor wiring wrong or something.

This is what is on the Warp9 forum for this.

!!!WARNING: A motor seems to be stuck backing off of a home switch! Check the diagnostics tab to see if the Home switch indicator is active when the switch is not!

If it says that, that means that the ESS has been backing off of a homing switch for at least 2 plugin main loop cycles. (2 cycles / 40 Hz = 1/20 of a second.) I will change that to be 5 cycles.

It is a warning for users that are just setting up homing and have their limit switch wired wrong or have the active high/low set wrong. What happens then, is your homing routine thinks it is immediately on a switch and starts to try to back off, and then it is going away from the switch forever. So then the user reverses the homing direction, and then it approaches the switch at backoff speed and stays on the switch. So this is a message to say that you are doping it wrong.

However, if your log file shows that you are approaching the switch, and you hit the switch and then you are backing off of the switch, and then this message shows up - then you may ignore it, you are just backing off really slow which is okay. I’ll add a little more to the message to clear this up.

Plus you may disable the report. Open up your profile’s Machine.ini and search for “iDisplayStuckBackingOffOfAHomeSwitchWarnings” in the ESS section. Set it to 0 if you do not want to see those messages anymore on the history/error line in the screen set.

If your machine is configured correctly (as an AVID it should be, the message was meant for those building their own machines), then its ok, and it will probably go away on ESS 283 or newer.

If you can turn on your diag log and send it to me at jnwdwks@gmail.com, I can look through it to see if anything else is going wrong in the homing process.

1 Like

One thing to check is that both of your Y motors are working correctly and there are no mechanical issues in the drivetrain. I have seen a couple times where someone had the master motor driving the gantry, but the slave’s pinion was not engaged on the rack. This wasn’t obvious because it would jog ok (if you weren’t looking at it real close), but would mess up the homing because the master couldn’t pull the slave side close enough to the sensor to trip it, or won’t be able to back off to untrip it. Either of those will hang up homing.

Thanks, Jim. I’ve been away from my machine this past week and won’t be back to it for a week or more. I will send you my diagnosis log when I get back to it. I appreciate you.