Z axis homing issue

So I got the Z axis to go in the right direction. Now though, when I try and home the z axis, it just keeps trying to move, even after the light turns on for the limit switch and it hits the hard stop. Here are my homing/soft limits in the configuration page. Do I need to jog the z axiz all the way down, then zero z?

You can home from anywhere, except the point where the axis limit switch is already tripped, so just make sure you are backed off all sensors before homing.

Your homing setup page looks ok. Are your homing sensors all set up correctly in the ESS plugin (below is a snapshot of mine, ignore motor 4, I have a rotary axis too)?

When the Z limit switch lights up on the machine, does the corresponding button light up in Mach 4?

The Z++ light comes on, but the Z light under homing sensors stays on, even after I back the z axis off the limit switch.

Sounds like it’s either sensing something it shouldn’t be, or a faulty sensor. Can you swap the sensor with another one and test?

We’re assuming a lot here without additional context. If these are sensors from Avid, they should be the right match for the system. If they’re not, you might have the wrong polarity.

The sensors are from AVID. I’ll try swapping the sensor with the X axis sensor and see what happens. But this is what the diagnostics tab looks like.

Also here is my Homing config.

Do you have stock AVID steppers or did you build your own with servo’s? The home to index pin is not for steppers.

They are stock AVID NEMA 23 steppers. I’ll change them and see if it works!

Thanks jjneeb! That’s what the issue was!

1 Like

Rock on, Jim’s eagle eye!

Jarred, I just want to put this out there in case you aren’t aware of your present situation and find yourself wondering why your experience is different (and frustrating) from others.

One, I notice your ESS plugin version changed from the first post to the last post, so maybe you’re troubleshooting some 3rd party integration and this is intentional. The last two official Avid CNC Mach4 releases contained 283 and 298, but never 284 from your last picture. If you’re using something that recommends 284, you might just jump to the supported release (2.4.3) with 298 included.

Two, the fact that the Home To Index Pin was enabled speaks to something being off. Again, maybe this is something you’re working on intentionally. Otherwise, if you start with a clean install of the latest Avid CNC Mach4 this would not happen. And there’d be a whole lot less head-scratching.