Problems Homing my Machine

Greetings knowledgeable people.

Having problems again with my homing sequence. I have the Z & X axis’s homing correctly. Lots of fine tuning off the sensors. It seems like the Y1 (my left as I look at the table) is lighting up and turning off like it should be. The Y Slave (on the right) is the one that seems to be having issues. The manual says to start at 3/16 in from the bumper. And that’s where I had it set. The slave side did not even trigger in Mach. So gradually moving it in with tiny adjustments, i get to this error. When it was not triggering in Mach4 the slave motor kept on trying to move until I stopped. Now with this error it is still trying to move, but it’s just creeping along.

Any suggestions?

Edit: when I manually trip both Y sensors using something metallic. The homing sequence stops, and says awesome done. Soft limits etc…

Edit 2: The Y1 sensor is 1/4 inch back from the bumper. The slave sensor is 5/32 back. When I have the slave sensor further back it failed. It’s right at the spot where the gantry triggers it now. Just tried for shits and giggles to move it to 1/4 inch to match Y1 and it fails to trip at all.
Edit 3: Posting on the Avid group on FB. it was suggested that I change on of the values on the ESS homing configuration. Not exactly sure what the change was supposed to do, but I changed it to -0.100

So after you adjusted the slave flag, and you started getting that warning, how does it behave when homing? They should both approach the flag at the approach velocity until they trip the sensor, then they back off at the backoff velocity (very slow) until the sensor untrips again. That is the home point. If they both do that, then it is working correctly. The warning is ok.

I was getting that error both before and after I adjusted that flag n the ESS config.

That was a setting that was recommended to fix it - it did not :frowning:
The Y1 trips and clears - but the slave just trips, and doesn’t clear.

So it doesn’t back up at all after tripping?

Thats correct, it slows after dropping the switch but it doesn’t back up. The Y1 does back up, and the motor stops and clears on Mach. The slave comes in to the home, trips the switch and slows down like it wants to back up, but it does not and never clears on Mach.

To rule out a bad sensor or cable have you tried swapping the Y sensors to see if the problem follows the sensor?

I have not, but I’ll try that today when i get into the shop.
Although, when i trip the sensors manually during homing. Everything works like it should. I get the hollering successful , soft limits messages. So pretty sure sure the sensor works

You can also try a fresh install of Mach. If you don’t want to lose your settings you can rename your Mach4Hobby directly to something different and then re-instsall Mach to see if that changes anything.

You may want to get in touch with support too. They can help you out.

Support is unable to help me without a service package. I’m not the original owner of the machine.
I’ll try the backup and reinstall today.

It should not slow down as it moves towards the sensor. It should approach at the Approach Velocity only, trip and stop, and retract until it untrips at the much slower Backoff Velocity. What you are saying makes me think its backing off in the wrong direction, then it can’t untrip the sensor, so then it times out and thats why you are getting that warning (this is actually the scenario for which that timeout and warning were put in for).

I remember seeing something about this in the past, I’ll see if i can find it to see what could cause that.

That is what’s happening, the motor is still moving forward and not going back

Can you send me a diagnostics log from the homing process? send to

So I removed Mach from my machine - ( saved the license etc) and reinstalled. Same problem

I’d just like to give a massive shout out to Jim Neeb. He eventually pointed me in to check the actual drive on the gear rack. I just want tensioned enough for the gantry to engage on the back stroke, and as such it couldn’t finish the homing cycle.

Thank you Jim.


@jjneeb is awesome!

Thanks Jim!