Rotary Axis problems


I have bought the Avid rotary axis few weeks ago and now I’m doing some tests.

I would like to machine a penguin that I have draw on Fusion (see picture below) and I’m using Vcarve for the routing.

and Below is what I have machined. The length and the width of the penguin are correct.

I don’t know why I get an ugly penguin. I don’t know where the issue come from. Gcode, wrong config of the axis on Mach4, wrong post processor on vCarve ?

Does someone know what append ?

Thanks and sorry for my bad english


It appears you Stepover is too large. You didn’t mention what roughing and finishing bits you’re using.
Roughing: use 40% stepover
Finishing: use 10-12% for 1/4" Ballnose, 8% for 1/8" Ballnose.
Use the Avid CNC Wrap X2A or Y2A depending on the way your rotary is set up.

1 Like

You are using the right post processor (or it wouldn’t have worked at all).

I agree with JRG, your stepovers are too big, and possibly you didn’t leave enough machining allowance between the roughing and finish pass.

If I were doing this piece, I would use a 1/4" ballnose for a roughing pass, with a 30-40% stepover, and around 0.060" allowance. Then I’d finish with a 1/32" or so tapered ballnose, and something like 0.005" step over to make it really clean.

It also looks like the block of wood you used wasn’t wide enough for the wings?

The carving seems mirrored from the image did you do that or maybe you have some setting off on mach3 like axis going in the wrong direction.

Your model has undercuts and vCarve is not a 4 axis CAM package. So your g-code is 3 axis, one axis being a rotary. As such the undercuts on the model will never be touched.

You would still need to adjust the undercuts if you used Fusion 360 but at least the wings and nose would be machinable.

Right now, besides the undercuts and limitations of 3 axis milling the only other problem I see is the model is scaled to large for the stock.

Below you can see my roughing and finishing parameters :

My stopover seems correct

Thanks for the information about the undercuts, I was a looking a parameters in VCarve to machine undercuts, but apparently it is not possible.

My stock was large enough (2cm more everywhere), at the first pass of roughing my cnc machine the wings in the wrong place, then the other passes was correct and for the finishing pass every part of the body was shift.

It seems like between the different passes the rotary axis gets out of sync.

“True 4 Axis” machining is very expensive. The cheapest solution on the market is Fusion 360. The AvidCNC OEM Mach4 will perform true 4 axis machining out of the box. You will need to define the machine as having 4 axis in F360 but the post processor already supports it.

I have no experience with that vcarve thing, sorry. :disappointed: