Setting up Mach4 norton issues

Hello, newbie here. I’ve been able to connect to the machine thru the computer and can jog the machine along all axis. Ran into a problem when I tried to test the spindle. I cannot start it with Mach4, button turns green, nothing happens.
Also, during the setup, I found errors relating to Norton. I uninstalled Norton, fixed 1 of the 3, but the other 2 still say I’m using Norton. Restarted several times, still the same.
Any ideas? Am I missing something obvious? Thanks

If you set the spindle RPM to like 10,000RPM and turn it on in the software, what’s the LCD on the VFD inside the spindle control cabinet read? It should read something like Fxxx (higher than F133) and the indicator next to ‘RUN’ should be lit.

If that checks out, it may be the cable between the spindle control box and the spindle motor. Despite the little plastic guides inside the connectors, it is not too difficult to force it in wrong which means the power and command pins aren’t in the right positions. Easy fix: disconnect (both ends), look very closely at the orientation, reconnect (both ends).

If that doesn’t check out, it may be the cable between the CNC control box and the spindle control box.

1 Like

It was something simple. I had to tighten the cable on the spindle. Uninstalling and reinstalling the Mach4 software also helped.

1 Like