Updating Avid CNC Mach4 Version to v. 2.4.2

These were just an example to help you. The file is 392 lines long, and all the errors are handled by those 4 lines. It’s literally 1%; 4/392.

Oh! You are a user interface guy! I am so sorry.

I was wondering why your web site was wordpress. But yeah, this all makes sense now.

Have a great night :slight_smile:

If anyone is having issues with G31 probes being inaccurate or causing errors we have identified an issue in our current Mach release related to this. On some setups (not all) a repeated G31 probe causes an error that increases the more you probe. We have a temporary workaround figured out now, and a software patch in the works.

If anyone sees this please contact support.

Hi Eric,

I have contact both NFS(Mach4) and Warp9(ESS). NFS and ESS both confirmed there is a problem with the ESS 283 when using the G31. This is what Greg from Warp 9 said to me about the issue.

I have some good news, which is that we have identified the reason for the long delay. Turns out a couple of different threads were both trying to read and write some variables to make them available for the user, and it was causing some deadlock that made for a really long delay. 0.8 seconds! Now it completes in a millisecond and retracts soon after that (there will be delay in comms with Mach to sync to the current position and to receive a trajectory of points to retract).
If you don’t hear from me, please write back in a day or two and I’ll give you an update.

Going by my discussion with Greg, the long delay with the G31 movement is causing weird problems. I have experienced the rapid movement that I have seen much discussed. I wasn’t using the AVID setter but a G code subroutine when this happen. I did try using the AVID touch module and am kind of glad I didn’t.

I went back to my original installation of Mach4 and ESS. Everything is working as expected. I will wait for an update from Warp9 before trying again.

This post reminds me that I should contact Greg to see if there is any progress.


Glad Greg is helping you out. Our support fix right now is reverting to an older version if users see this issue (not every user is seeing this issue)

While you’re free to run whatever version of the ESS you want, I’d advise you (or anyone else reading this) to use the version provided by us. We take Warp 9’s plugin and roll it into our own build of Mach that has extra options for our machines.

For folks seeing this issue you can contact our support and we can set you up with an older version of Mach, and when we have a patch ready to go we’ll post that (it shouldn’t be long)

I’m using the original version that I downloaded when I first set up my AVID in Dec 2020. I’m usually anti-upgrading unless there is an issue (which I didn’t have) or there is a new feature I wanted. I wanted to try Corbin’s update for the ATC and one other feature I saw mentioned on AVID’s change log.

I’m currently back using v 4.2.4517 of Mach 4 and ESS v260. I personally never experienced any of the issues with tool rapiding into the AVID touchplate or my toolsetter as I have seen Corbin or other mention using the original verison I download when I setup my AVID CNC.

The only thing I do after setting my working offset when using AVID’s touchplate script is to reactivate G43 for the current tools and set the z to 2", the amount it retracts after the script ends. That fixes any issue I found using the touchplate. I did contact AVID since the touchplate lau script is compiled and wanted to modify it for my use but that was a no can do from AVID. So I add a button to activate the G43 and set the correct z.


For those that were having issues with G31 probes, we fixed it:

Is this a fix to the ESS as well or just a work-uh-round in Mach4?

We’re at ESS 298 in this version. We worked with Warp 9 on this fix.

1 Like