4x8 Avid CNC w Mach4 Hobby stops at random

I have a 4x8 setup, Nema 32, running on a Windows 10 laptop with Mach 4 Hobby w/ AVID CNC. Porter Cable router. While running programs, the program will stop at random, leaving the router running. If I click “Feed Hold” and then “Stop” and back up a few lines and then proceed, the machine loses its position and the program gets offset. Mach 4 seems to know the program is offset, as the toolpath drawing in Mach4 will be offset from the vector image. Occasionally, the machine “jolts” while the gantry is moving, like it experienced a hiccup. This usually happens during longer travels of the x or y axis.

Size of the file seems irrelevant, as this will occur both while doing simple cutouts and while doing more intricate carving programs. Where it stops in particular seems to be completely at random. It is not always offset in the same axis, as I’ve had it lose all three at separate times.

I did have a problem where the machine seemed to lose it’s home position. After that, I made sure my ethernet cable between computer and machine were separated, and updated all the software.

I updated VCarve pro, Mach 4, and updated the AVID post-processor. I updated the SCS and ran the program to set my laptop at the ideal parameters. I’m trying to figure out what the heck the issue could be. My next guess would be EMI from the router. I’ve tried running the same programs with the router off and no bit, and so far I haven’t had any hiccups (I havent tried that with any of the longer more intricate programs though). Where do I go from here? I need this thing to work properly so we can put it to use.

A few questions:

Is this a new machine and its done it from day 1, or is this something that has been working for a long time and just started acting up?

Is the location of the “jolt” random, or a specific spot in the travel? Does it do this while jogging sometimes too, or just when running Gcode?

When you say you ran the ethernet seperated, you mean not routed next to power or other cables? Is that a good quality sheilded ethernet cable?

It was a used machine. I can’t say whether it had issues before, but it has been doing this from day-1 when I got it. The location of the “jolt” is random. Not sure if it’s ever done it while jogging or not.

One the ethernet: that’s precisely what I meant–separated form the power cables. Going to replace the cable with a shielded cable and see if anything improves.

I have witnessed this many times. Especially in the new version it is 10 times worse.

It’s a bug in Mach4.

And no, Newfangled will not admit to it. If you complain they will delete your account so be careful.

Just blame your wifi and move on :crazy_face:

Mine has done it a couple times over the years. But if its happening frequently, the two most common things I’ve noted (from reading peoples resolutions on this and other AVID forums) is either a bad eithernet cable, some kind of electrostatic problem with a dust collector hose in close proximity to some of the wiring, or PC issues (either a very low performance laptop, or background processes running on it that were taking up too much resources).

I had some major issues with random skipping steps on two PCs. I reinstalled Windows, updated all drivers, followed all the PC setup procedures in the Avid docs and still had the issues. New ethernet cables, and checked all wiring. Tried to isolate the issue on a per-axis basis. The problem was on all 3 axis so it wasn’t the motors or motor control. Got a brand new laptop and I’m on the longest stretch of no step skipping. I sure wish there was a native Linux platform or something like a rich auto controller to communicate with the machine.

1 Like

I only have one machine that uses Mach4. All of my other machines are LinuxCNC and they never have issues like this.

I tell folks my oldest CNC is a X3 conversion built in 2010. It uses the original Intel i3 with 4GB of RAM and parallel ports. It never has an issue with wifi or even running card games when in use :crazy_face:

Similar here: I picked up this Windows 11 mini PC to dedicate to the CNC and haven’t noticed more jolts. Yet.

I wanted LinuxCNC but went with the turnkey Avid so I could get going on projects. I still feel like I should make that mod someday.

Yep, that was my thinking too. I just wanted to install and run. I won’t make that mistake ever again :rofl:

Getting a mini-computer to replace the laptop I’m using now. Just had this happen, after grounding my dust collector hose and installing a shielded ethernet cable.

Ugh :disappointed:

Well, call it “modern art” and sell to somebody in California :rofl:

1 Like

Have you checked for Loose wiring in your control panel there’s been issues like that :thinking:

Just curious how old was the laptop?

You’re not missing steps, you’re missing the whole staircase… :wink:

The laptop is from 2011. It’s an HP Elitebook with an i7(2.7GHz) and 16GB ram. It’s running Windows 10.

I went through and checked all the connections. They seem fine.

The same toolpath, started again in Mach 4. The toolpath is cutting properly (for now)but shows as off in the program

Do you regen toolpath after you load the gcode?

Yes i think you’ll have better luck with the new computer :grin::+1:

I uninstalled OneDrive (even though it was supposed to be disabled by SCS), Office, and a bunch of other things. I have the identical carving being done now and so far no issues. It’s gotten past where it got last time.

Installed the mini-computer and so far no hiccups. Carved this the other day no issues.

1 Like

Awesome! And the flag looks great! Too!